Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I plug a USB thumb drive into my Win7 PC, it no longer auto-launches the window giving me options like "Import Photos" or "browse". The drive is recognized but nothing autolaunches.

Similarly, CD's don't autoplay either.

I verified that Win7 is set to autoplay, per method 1 and 2 of: http://www.sevenforums.com/tutorials/27544-autoplay-enable-disable-autorun.html

FYI, there is a similar question (but for Windows XP) here on SU.

share|improve this question
    
Sorry to ask, but are you sure you have checked under "AutoPlay" the options "Use AutoPlay for all media and devices", and also set all items to "Ask me every time"? How about clicking the "Reset All Defaults" button at the bottom and then restarting? –  caliban Jan 4 '11 at 17:16
1  
On a side note having Autoplay disabled is not a bad idea. The DoD was plagued by the Conficker worm which exploits the Autoplay feature on Windows. stripes.com/news/dod-on-high-alert-for-conficker-worm-1.89829 –  Sahil Jan 4 '11 at 23:37

3 Answers 3

up vote 1 down vote accepted

solution summarized from another website (wanted to note it before I reboot and try):

In the following Registry Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer and possibly (but not needed in my case) in: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

The value:

"NoDriveTypeAutoRun" set as 0x000000FF (255) which I have found out disables Autorun on every device.

Set this value to decimel 145 (the default).

Other value (I've not confirmed they are correct)

0x1 Disables AutoPlay on drives of unknown type. 0x4 Disables AutoPlay on removable drives. 0x8 Disables AutoPlay on fixed drives. 0x10 Disables AutoPlay on network drives. 0x20 Disables AutoPlay on CD-ROM drives. 0x40 Disables AutoPlay on RAM drives. 0x80 Disables AutoPlay on drives of unknown type.

0xFF Disables AutoPlay on all types of drives.

share|improve this answer
    
just delete the entire key –  caliban Jan 4 '11 at 17:22
    
When I renamed the Value and rebooted, my PC wouldn't start (it did a System Restore to reset that value). I'm guessiing that deleting the key would have the same (bad) effect. –  Clay Nichols Jan 4 '11 at 17:37

The link to seven forums should sort the problem out. However, if your computer is part of a domain this may be restricted by group policy. It could also be disabled by your antivirus.

Can you try running it with your antivirus disabled (could be risky unless you know USB drive is clean). Can you confirm whether you are part of a domain?

share|improve this answer

The easiest way to disable autoplay is by using Autoplay Disabler Pro. I use it, it's cool app really.

share|improve this answer
1  
Just to note that the site this is linked to is down –  Journeyman Geek Nov 4 '12 at 0:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.