Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, I'm getting no joy from Asus or Microsoft on this, so hoping for some clues on how to narrow down the cause.

I have very frequent OS freezes, always & only when running Remote Destkop Client (mstsc) in Windows 7 x64. I never have a bluescreen, and there is never a minidump. The display & input just freezes -- no keyboard, no mouse, and sound will just continue the last wavelength if any. So far, I can't find a way to trap the hang given that there's no bluescreen; advanced startup & recovery settings for system failure are "Write an event" checked, "Automatically restart" checked, and "Kernel memory dump".

I've updated to the lasted BIOS, and tried a few different graphics drivers, both generic & ATI. I've also tried disabling Aero, and everything about the remote desktop experience (incrementally unchecked every box in the mstsc -> options -> experience tab), even disabled/unplugged external monitor to make sure it wasn't a dual-monitor issue.

My specs are:

Asus G73jh notebook
8GB RAM
ATI Mobility Radeon HD 5800 Series graphics
    (recently tried driver versions 8.791.0.0, 8.801.0.0)
American Megatrends G73jh.211 BIOS (7/27/2010)
Windows 7 Home Premium x64

Windows Memory Diagnostic passed all of the following at least 3 times with no errors:

MATS+
INVC
LRAND
Stride6
WMATS+    
WINVC

This notebook is better than most at removing heat (laudable vent design), so I'm not inclined to suspect thermal causes (especially since running 1080p video for hours has never caused a freeze, but mstsc does, reliably, within 5 minutes to an hour).

This did seem to start happening after a Windows Update, but I've since reverted every patch applied since a week before the first occurrence, with no joy. (And I'd only had the PC for a couple weeks before that, so it could have been chance + less actual time spent remoting at the beginning.)

I'm at my wits end, and I bought this laptop primarily as a remote terminal client (go figure, right?) Any ideas on how to identify the cause of this?

Thanks!

UPDATE: Found a viable workaround: Using mRemote in lieu of mstsc, I've had multiple RDP sessions running for over 24 hours with no freezes. This is odd, since under the hood mRmmote uses MS's DLLs & OCXs, but somehow there must be a difference.

UPDATE 2: Issue continues; freezes now also happen when accessing Google Plus using the Chrome browser (any version, stable through canary). Even displaying the Plus notification icon in GMail in Chrome will frequently cause it, while accessing Plus in any other browser will not (have verified this pretty exhaustively). There must be something substantially different in Chrome's use of hardware, perhaps via their custom Flash implementation). Also discovered that freezes can still occur with mRemote, it's just less frequent than when using MSTSC.

share|improve this question
    
Found that Microsoft KB 976902 does not uninstall. Linked at support.microsoft.com/KB/976902. Do you have that update installed on your computer? –  Ron K. Jan 20 '11 at 21:42
    
Interesting... your comment about having the same issue on the exact same computer (but with Win 7 Enterprise instead of Home) seems to have disappeared. Anyway, I don't have any Adobe processes running. KB976902 is installed, but that happened well after the problem started. Also, this has happened twice outside of MSTSC now; once in MS PowerPoint Viewer 2010, and I wasn't doing anything special the other time (browsers and Excel open, IIRC). Have tried some more NIC and display drivers, but still banging my head against the wall with this one. –  Paul Smith Jan 25 '11 at 19:14
    
Update: As of today, this is still happening. Have applied myriad Windows updates and ATI Radeon driver updates since asking the question. There have been some great & well-informed answers so far, but the problem unfortunately remains unsolved. Hopefully I'll be able to click the big green check mark one of these days! –  Paul Smith May 19 '11 at 10:12
    
Interesting your comment about Chrome because I'm experiencing similar symptoms. After months of using RDP to same computer now it's freezing on me and there seems to be some relation to using chrome which I've also been using a long time. Too early in my diagnostic process to tell what's going on but seems similar. Did you ever resolve this? –  User Jun 21 '13 at 22:48
1  
I “resolved” it by abandoning that PC. On that PC, I never was able to safely use Chrome to access Google properties that showed the notification bar. –  Paul Smith Jun 23 '13 at 23:48

3 Answers 3

Using "msconfig", I disabled everything in the startup section. Doing that made the computer run better and remote desktop no longer froze the computer up. So I re-enabled things in the startup a couple at a time until I worked down to the Adobe startup items (Acrotray, CS5 manager and Adobe updater - there are a couple of others). System still runs great and no more lock ups. There must be something in the new Adobe stuff that doesn't mesh well with the ASUS software or drivers. The Adobe apps that I have are Design suite CS5 and Acrobast X Pro.

share|improve this answer
    
Bridge often produces errors when I remote in as a result of the video device switching. It could be the issue. –  Benjamin Anderson Feb 8 '11 at 22:43

Sounds like you've tried every reasonable action, including a system restore. This might be a bit of a pain since you'll have to back everything up, but have you thought about trying a clean install of Windows 7? That might help you resolve the stop error or at the very least give you another option.

share|improve this answer
    
That's usually where I would go next (or revert to an Acronis backup from before the problem manifested). Unfortunately, this Asus didn't come with a Windows 7 disc nor an easy 'reset to factory' option. I guess I could burn an MSDN product key & then reinstall all my software, but that would mean discarding the OS/licence that came with this laptop, which was only supposed to be a simple dumb terminal anyway. In a perfect world, there would be a way to start Win 7 with a trace switch that slowed performance to a crawl but left evidence of failed driver instructions. ;) –  Paul Smith Jan 5 '11 at 6:29

When I've experienced this, it was related to the Graphics drivers or the NIC driver. the graphics driver one occurs most when you terminate the session, and Windows has to switch back the the hardware driver, instead of the software virtualization. If you're still connected and it is occurring then it's the result of a driver actively being used. It could be the sound driver, but my experience has been the NIC driver most often.

share|improve this answer

protected by Community Jun 1 '11 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.