Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Want to copy the file name quickly in windows. I always use rename, copy , but feel it is quite slow. Any better way?

share|improve this question
4  
Press F2 to rename, Ctrl-C to copy. Two keystrokes without any additional utilities. –  Daniel Beck Jan 5 '11 at 6:05
1  
@Daniel - I think your comment should be an answer –  Nifle Jan 5 '11 at 6:07
    
@Nifle Didn't seem worthy of an answer, but the upvotes and your comment are quite persuasive. –  Daniel Beck Jan 5 '11 at 6:41

4 Answers 4

up vote 8 down vote accepted

Press F2 to rename, Ctrl-C to copy. Two keystrokes without any additional utilities.

share|improve this answer
    
Bonus info for Mac OS X users: Press Return to rename, Cmd-C to copy. –  Daniel Beck Jan 5 '11 at 6:41

You can get a free context menu utility, rightfully named "Copy File Name Utility", that will add that option to files:

alt text

Compatible with XP, Vista, 7 (32 and 64-bit editions). Just 11kb.

share|improve this answer

Try clicking on a the file and then clicking on it after a short pause it will get into rename mode and then you can copy the name of the file .
Or you can drag the file to run menu and it will show the file name (but along with the file path) . Or you can do the following if you have too many file names to copy
Launch command prompt
Navigate to the folder you want file names from
Type out the following : dir /d>listoffiles.txt
This will create a txt file with list of all the files/folders in your folder in you D drive.

share|improve this answer

If you are just trying to copy the files names into the clipboard try the following -

  1. Click Start, click Run, type cmd, and then click OK.
  2. change to the appropriate directory using the cd command.
  3. type dir
  4. Using the mouse, highlight the file names you want to copy.
  5. Press the right mouse button - this copies the selected text onto the clipboard.

You may need to enable quick edit mode, follow the instructions here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.