Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok... I've searched a lot for this, but it's not an easy question to search for!

When I open any files (xls, or xlsx) in Excel 2007, excel acts like it's a read only file, essentially creating a new file with the name plus a 1 on the end...

Eg. I open NewDoc.xlsx Excel opens it as NewDoc1.xlsx and the save button brings up the save as dialogue in my default folder.

Does anyone know how to set it back to allowing me to open, edit and save a document without having to browse to the original document and save over it!?

My immediate thought was access permissions, but the file is in a network folder with my user given Full Control, I also tried creating a new file in that folder, and also on my local machine just in case - same result. To make it even stranger, if I browse to the original file using the save as dialogue, it will let me save over the original, without any further prompts.

share|improve this question
    
What happens if you save the file and then save it again, I mean if you do this twice and you end up with one file have 1 appended to it's name and second one is it again appends a 1 to it or saves it with 2 appended to it? It might be some type poor mans versioning behavior that you are dealing with. –  Arjang Jan 10 '11 at 18:29
add comment

3 Answers

I seem to have resolved this by running the Repair portion of the Office 2k7 setup installation option

(For future reference, this is accessed via Add/Remove programs in the control panel and clicking 'Change' for MS Office 2007, and then selecting Repair)

Chris

share|improve this answer
add comment

Chris, that's the behavior I'd expect when opening an Excel template file. I see at this link that registering and unregistering Excel solved a similar problem for somebody: http://www.officekb.com/Uwe/Forum.aspx/ms-excel/89140/Excel-won-t-open-the-original-document

share|improve this answer
    
Didn't work for me, same behaviour. I'll try searching for terms like 'wont open original document' now though, thanks. –  Chris Jan 6 '11 at 8:46
add comment

I solved the problem by changing the Read & Write permissions in the Get Info screen to Read only, then back to Read & Write. tlc

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.