Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Snow Leopard, I'm having issues with permissions in my Sites folder. While I can navigate to localhost/~username and read any files or folders there, the same permissions have not been applied to enclosed items, and I get a 403 error trying to access them in the browser.

If I select one of these enclosed folders and get info using Finder, I see the user 'Everyone' is set to 'No Access' but I can't change that (this behavior seems buggy, actually).

And if I select my 'Sites' folder, the tool to 'Apply to enclosed items' is grayed out...

Is there a Terminal command I can use to grant 'Read Only' access to my Sites folder, and all it contains, for the user 'Everyone'?

share|improve this question

1 Answer 1

Since OSX is BSD-ish, try

chmod -R o+r Sites

Your directories will need:

chmod o+x [whatever directories]

Without a Mac at hand, you might be able to do the above by:

find Sites -type d -exec chmod o+x \{} \;

which will find all of the directories under Sites and allow 'others' to enter the directory.

share|improve this answer
1  
combine the first two into chmod -R o+rX Sites. The capital X option will only add execute/search permission for files which already have it set for some user. –  Doug Harris Jan 5 '11 at 17:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.