Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is an external drive, formerly a boot drive which is now in use only to access music files (sibelius, audio, midi, live, logic etc.) without transferring the data into a new boot system, partly because of the issue I am about to describe, but mostly because the majority of the data is mainly there for archival purposes. The user is a composer and prominent musician and needs to be able to rehash the data at will.

I have tried several things - here is a list:
- make complete filesystem clone with antonio diaz's ddrescue
- run Disk Warrior on copy, repair whatever errors occurred
- wipe out all ACLs on entire drive
- set all permissions to the same value - wide open 777
- remove any system data (applications, system files, including hidden files to the best of my knowledge) by selecting only non-system/app data and using Carbon Copy Cloner to put only the data of interest onto a newly formatted drive
- transfer data to newly formatted drive folder by folder, resetting the spotlight index in between adding each to observe for issues (interesting here is that no issues occurred except for in Documents folder - when I transferred only the Documents folder to a newly formatted drive on its own - no trouble. It appears almost as thought it may not be the content but the quantity or specific combination of data that results in problems)
- use DataRescue to transfer the data to yet another newly formatted drive to expose any missed hidden files

Between each of the above steps I stopped Spotlight (search for anything beginning with md in Activity Monitor - All Processes and quitting it), deleted the .Spotlight-V100 directory from the affected drive. Restart Splotlight indexing by adding drive to Spotlight privacy list and removing it.

In each case the same issue occurs - Spotlight begins indexing normally (or so it seems), then the index estimated time increases, usually to 4 hours remaining. This is where it gets stuck and continues to predict 4 hours remaining but never finishes. Sometimes I can't eject the drive and have to quit the md.. processes from Activity Monitor to be able to eject the drive without Force Eject. Once I disconnect the drive after the 4 hours remaining situation - if I reattach it, Spotlight forever estimates remaining time and never gets going again.

So there it is.

It is apparently not a filesystem issue, not a permissions issue and not tied to any particular piece of hardware or protocol (used USB and FW drives). I have tried this on several machines (3 to be precise) and in 10.5.8 and 10.6.5.

Simply disabling Spotlight on this volume is not an option because the owner has no clue where things are as the data on the volume dates back to music projects and compositions from 2003 and before. He needs to be able to query for results.

Anyone got any ideas?

---update 2-6-11

Since I have not received any responses except the one below which appears to misunderstand my point, I am updating this post hoping to get more responses. I have used the terminal command

sudo opensnoop -p PID

where PID is the mdworker process ID to try and determine what Spotlight is doing and hopefully find the files it's having trouble with. Here's what happens:

After indexing for a few hours, mdworker is gone. It no longer shows up in Activity Monitor under "All Processes" and the Terminal window with the opensnoop result stops moving. I then proceeded to execute the same command on mds to see what it was doing and here's what I get, repeatedly:

501 57 mds 21 /

501 57 mds 21 /Volumes/Sno Leppard

501 57 mds 21 /Volumes/Tiger

501 57 mds 21 /Volumes/Leppard

501 57 mds 21 /Volumes/Disk Warrior

501 57 mds 21 /Volumes/ONM Data

These represent all the volumes currently mounted in the system. All except ONM Data, which is the one I am trying to index, are excluded from SPotlight indexing at the moment. The sequence above repeats over and over, with slight variation, sometimes skipping one of the volumes.

Questions - what happened to mdworker? What is mds doing?

I will let this run until tomorrow morning and throughout the day and monitor for any changes. Any input would be very much appreciated. Even if you're not sure what the ultimate answer is, please alert me to anything you think I may be missing. Hopefully at some point we will figure this out...

Thanks,

M

__final edit__

I finally resolved the issue and here is how I did it.

I used the terminal command "sudo opensnoop -p PID" where the PID is the process id of the processes I was monitoring. I was looking at all instances of mds and mdworker running in the system.

After the third time through indexing the same data set (see info above), I contacted Apple and got to their highest level of support - they were flabbergasted as well. They advised me to install yet another default 10.6.6 system and try again. The same pattern repeated - mds and mdworker(s) would start indexing and eventually the spotlight icon would say 6 hours remaining and all mdworkers were gone, mds at 90% or so of CPU.

But I did finally figure out that the first time mdworker stopped like that, the last file it touched was always in the same folder. I excluded that folder from spotlight search and the rest of the data set indexed within about 2 hours with no strange behavior or failures.

I copied that folder to another machine and Spotlight barfed immediately. Exclude that folder and all is well again. I have no clue what is causing this behavior, still, but I did find a functional solution to the problem.

Anyone with a similar problem - run opensnoop on all instances of mds and mdworker and wait patiently for wdworker to exit. Look at the last file it touched and exclude the enclosing folder from being indexed.

I was able to repeat the issue and solution on 2 different installs and 2 different copies of the data set.

Hope this helps.

If we find an actual cause of the folder being such a problem (it is called MICHAEL BRECKER RECORD SOLOS and contains almost 1 GB of audio related files - performer, live, SD2 - things like that), I will edit again to let you all know.

Thanks for ay attempts to help,

M

share|improve this question

1 Answer 1

I don't know if you resolved the root cause of the issue, but in trying to research my own related problem, I came across your post.

I was wondering, since you identified a folder with the problem, did you open every single file in the folder to verify the integrity of the files?

I can't tell what kind of rights the mdworker has in the system, but it frequently gives me errors that are apparently related to it not having the proper rights to access the file. This doesn't seem to be relevant to your problem, though.

But from what you're describing...? It really seems like it's crashing while reading a file - it oculd be a corrupt file, a file with a virus, or a file that the new system doesn't have the proper extension/codec/plugin to read properly? Is that possible?

However, with all that said? I'm not saying this would at all be ideal for the client, but the first thing I thought of was the difficulty you might encounter reading a system drive. I'd consider getting a copy of "Find Any File" by Thomas Tempelmann it can find files in places Spotlight doesn't look at by default - and somehow, some way, it does it just as fast as spotlight. It's donationware and it might help for those times where you need to look a little more thoroughly or double check the spotlight results.

I hope this is helpful to someone else if nothing else to spur some ideas about things to try or things to look at.

Rob

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.