Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a /29 range of public IP addresses assigned to me by my ISP. I'm trying to configure a SIP VOIP handset to register with my VOIP provider who recommend using public IP addresses rather than NAT.

I have a DrayTek 2820 router flashed with the latest firmware and have configured my router as per DrayTek's FAQ at:

How do I use a public subnet on the LAN (non-NAT operation ) ?

My IP range is:

xx.xx.94.16 -> xx.xx.94.23

This gives a usable range of:

xx.xx.94.17 -> xx.xx.94.22

My router's public IP address is: xx.xx.94.17, the SIP VOIP handset is allocated xx.xx.94.18.

I have a second internet connection and via that I can ping the handset.

However for some reason I can't seem to get it to register with the provider.

I tried adding a new Firewall filter to pass through from WAN to LAN:

Source: ANY, Destination: xx.xx.94.18, UDP - Ports 1024 -> 65535

Out of interest I also tried opening port 80 to see if I could browse to the phone's admin web interface but no joy.

I know that my ISP aren't blocking inbound service ports because I NAT Port Forwarded port 80 to one of my internal web servers and it rendered a test page I had set up.

All the NAT settings are reset to factory defaults, i.e. there are no Port Redirection, DMZ Host, Open Ports or Address Mappings configured.

The handset I'm using is a GrandStream GXP-2000.

Is there anything else I should be doing?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Give Mikey's guide on 2nd LAN subnets a miss. Take out the firewall filter, disable 'for IP routing usage' (2nd subnet) and have a read of this guide on address mapping instead:

http://www.draytek.com/user/SupportFAQDetail.php?ID=1353

Incidentally, I have never had an issue connecting a SIP phone via NAT, provided that you setup the right port forwarding and made sure the phone is using a STUN server.

I have a Draytek 2820 to hand AND a GXP2000 so do come back if you need more help.

PS: Who's the VoIP provider?

share|improve this answer
    
AAISP, they're not keen on NAT. It did previously work with NAT on my old Zyxel P660 but stopped working with the DrayTek. I'm an old hat at NAT port forwarding so thought I had this sussed (another provider voip.co.uk worked fine with the draytek). Anyway I have this range and thought I'd try using a public IP as recommended by AAISP but I've come unstuck. –  Kev Jan 6 '11 at 1:21
    
Yep, I have run Snoms and the GXP2000 through 2800s and 2820s to voip.co.uk. The only other issue I have come across is if you have a V-series Draytek (with built-in VoIP support), they seem to trap all port 5060 traffic destined for devices on the LAN and so you have a move their internal ports (or the phone/s on the LAN) off 5060. Also watch out for the latest (as of around mid 2010) 2820 firmware as some had problems with it - there's some comments in the seg.co.uk forums about this. –  Linker3000 Jan 6 '11 at 1:29
    
Now here's the damnedest wierd thing. I reset the IP address on the GXP back to its private ip, subnet and gateway then rebooted and magically ALL of the services have registered. Nothing changed on the router. That FAQ on address mapping will come in handy though, so thanks for that. Think I'm going to invest in a Snom 320 though, this GXP is a bit rough around the edges. –  Kev Jan 6 '11 at 1:36
    
And even more bizarre is that router's firewall is back to factory default and I haven't even port forwarded RTP 5004 or SIP 5060 et al. –  Kev Jan 6 '11 at 1:43
    
Glad it's working. Yes, the GXP units are good value for money but a little plastiky. The Snoms are almsot the opposite - expensive but well built. I have had the occasional good luck buying Snom 320/360/370s on Ebay for around £80-£100 and you can sometimes pick up Mitel 5220/5224 ('dual mode' versions for SIP support) for around £45-£50 and these are fairly decent units too. –  Linker3000 Jan 6 '11 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.