Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever Colloquy needs to pop up a notification (for example, when you are PM'd), it uses its built-in Growl notifications, which really annoy me because they stay on the screen until they are clicked (at least NOTICE's do anyways).

I'd like to make Colloquy use the Growl that I have installed on my Mac, not its built-in Growl notifications. That way, I could change its preferences from the Growl .prefpane and it would match the look of all my other notifications. I seem to remember this being possible (maybe in a bug report or something), but I can't remember how. Thanks!

share|improve this question
    
I don't think it's because Colloquy is using it's own installed version of Growl, it's just because it's changing the settings used when it displays its notifications. –  Wuffers Jan 7 '11 at 14:53
    
@Mark No, that's not true. If it were using the system-wide Growl, its preferences would be configurable in the .prefpane. It uses its own built-in Growl as a safeguard for computers that don't have Growl already installed. –  squircle Jan 7 '11 at 14:55
    
Ah, ok, sorry. –  Wuffers Jan 7 '11 at 14:56
    
@Mark No need to apologize; we're all friends here on SU :) –  squircle Jan 8 '11 at 1:10
add comment

2 Answers

Colloquy has a preference under Alerts: “...and keep on screen until activated.”. Are you sure you don’t have that turned on?

I’ll set aside their stupid (and abusive, and terrible) behavior of bundling in Growl instead of using the System’s growl and/or prompting to install Growl (ala Adium).

share|improve this answer
    
Yes, I've turned that off in the preferences. It's not the staying on the screen I have an issue with, it's the "getting colloquy to use built-in growl" problem. Thanks anyways. –  squircle Jan 11 '11 at 21:20
add comment
up vote 7 down vote accepted

I lead myself to the solution from a posting on Google Groups. Turns out you have to force Colloquy to run in 32-bit mode in order to get it to show up in the Growl .prefpane:

Colloquy 32-bit

Then, you can customize the Colloquy notifications however you choose:

Grown screenshot

share|improve this answer
1  
it works! Thank you! –  Andrew Sep 27 '11 at 21:42
    
Tried this fix with Colloquy 2.3, 2.4 and nightly builds r4630 and r5138 with OSX Lion & Growl 1.3 (Appstore), but it didn't work. –  Chris Burgess Oct 26 '11 at 21:07
1  
works for me on lion with growl 1.2.2 and colloquy 2.3 (4617), thx –  cerberos Jan 31 '12 at 16:49
    
@Chris Burgess the growl api changed in 1.3 (something to do with getting on the app store) so many apps aren't compatible with it. I've reverted to 1.2.2 on lion and so far so good. –  cerberos Jan 31 '12 at 16:53
    
@cerberos Thanks. There are good alternatives now too; I ended up switching to Textual from the AppStore. –  Chris Burgess Feb 16 '12 at 18:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.