Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows Server 2003 running in a virtual machine, running some software that is trying to update a database within transactions on my Windows 7 machine (the host for the VM).

On my host I have edited the settings for Local DTC by selecting the following

Client and Administration

  • Allow Remote clients
  • Allow Remote administration

Transaction manager communication

  • Allow inbound
  • Allow outbound
  • No authentication required

However when I try to run the software I receive this error: MSDTC on server 'x' is unavailable. Whilst searching for fixes most just suggest making sure the service is running which I have.

Cheers!

share|improve this question

2 Answers 2

My notes on similar problems I have had point to this: http://support.microsoft.com/kb/839279

That KB article has detailed instructions on how to configure the service and the windows firewall.

Also, it seems that our SOP is to set to "Mutual Authentication Required" and not "No Authentication Required". It doesn't seem like your setting would stop anything but, if the MSKB article doesn't work out, it might be worth changing the setting if you can easily restart the service and/or server.

Also, our servers primarily talk to other servers, either SQL Server (via linked servers) or IIS servers, all of which are Windows Server 2003 or 2008. YMMV with Windows 7.

share|improve this answer

I have a MS Virtual PC XP Mode machine and just corrected the issue with the following steps:

  1. I enabled Remote RPC Connections on the VM

    Trouble Shooting MSDTC Issues with DTCPing
    Update to restrict anonymous remote RPC access
    DTCPing Download

  2. I shortened the computer name DTCPing itself would not accept the NETBios name because it was too long.

    Troubleshooting Problems with MSDTC
    Troubleshooting steps - 8

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.