Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 10.10 Maverick Meerkat installed. The problem is that the tap to click feature on my touchpad is too sensitive in ubuntu. It works fine with windows. I randomly end up clicking things while moving the mouse. Its very irritating. Any solutions ? I have a HP Probook 4410s laptop.

share|improve this question
    
Would it be acceptable to turn it off? I assume the trackpad has real buttons nearby. –  CajunLuke Jan 6 '11 at 15:16
    
i mean i could probably get used to it being off. But i would prefer a fix rather than avoiding the problem. –  tapan Jan 6 '11 at 15:30
add comment

2 Answers 2

up vote 21 down vote accepted

This works for me in Ubuntu 10.10

To see what trackpad you've got and what it's called, try:

xinput list

My device is called "SynPS/2 Synaptics TouchPad"

There are 3 finger pressure settings: low, high & press. See what their current values are with something like:

xinput list-props "SynPS/2 Synaptics TouchPad" |grep -i finger

Change the values with something like:

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Finger" 50 90 255

By increasing the second parameter, you require more finger pressure for the trackpad to respond. The first parameter controls release pressure, the third is to detect a button press (I think).

share|improve this answer
2  
I needed to put commas in between the numerical values, as running it without commas resulted in a non-functioning trackpad. Also, my values were 12, 35, 255, in case someone tries it and 50, 90, 255 makes clicking not work at all. I have an ALPS GlidePoint. –  user125456 Mar 29 '12 at 13:03
    
This also worked for me on Ubuntu 12.04 –  esse Sep 26 '12 at 3:47
3  
Works on 13.10 too, 10, 50, 0 seems to be a good setting on macbook 4.1 –  NoBugs Aug 27 '13 at 3:33
2  
on my macbook pro unibody the commannd was: $ sudo xinput set-prop "bcm5974" "Synaptics Finger" 10, 50, 0 –  elviejo Sep 14 '13 at 18:31
1  
This works even on the unstable release of 14.04. :-) Thanks! –  Ionică Bizău Mar 17 at 17:19
show 2 more comments

This may be silly but do you have gpointing-device-settings installed?

dpkg --get-selections | grep gpointing

Should show it if you do have it installed. If not try installing it with apt-get or aptitude.

share|improve this answer
2  
i do have it installed. No options from there really helped. –  tapan Jan 7 '11 at 8:27
1  
Thanks, that helped me on sony vaio. –  mreq Jun 30 '12 at 14:20
1  
thanks. this helped me on a thinkpad t500 –  jonny.milano Mar 18 at 6:41
    
Thanks. helped me on Latitude E5530 –  ring0 May 19 at 7:01
add comment

protected by Community Apr 23 '12 at 16:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.