Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed the rxvt shell, now I wonder how I am supposed to execute rxvt without having to start cygwin default shell first.

I have tried the instruction on the following site, but when I have made that .shortcut file rxvt will only execute briefly and then exit.

http://infrablue.tripod.com/cygwin.html

share|improve this question

3 Answers 3

up vote 5 down vote accepted

To sow more confusion :)

1) rxvt isn't a shell - it's a terminal emulator, specifically meant to emulate the DEC vt100 series physical terminal. The -e /bin/bash in the accepted answer is what kicks off your shell (bash in this case), passing bash --login to make it a login shell.

2) Besides rxvt you may want to try mintty. I find it more modern, and cleaner. It's a more native Windows style app, with Windows cut and paste rules. I like it better, YMMV. I have no Cygwin install in front of me to test this, but C:\cygwin\bin\mintty.exe -e /bin/bash --login should work

3) Also look at the chere command line app, which adds the registry entries to say 'start shell here' to your explorer windows. It allows you to say which terminal emulator to use.

share|improve this answer
    
mintty was a better option :) –  starcorn Jan 6 '11 at 19:22
    
Amusingly, Mintty is what I use as well. +1. –  dsolimano Jan 6 '11 at 21:17

Installing the rxvt package should have put a start menu entry for it into the Cygwin folder in All Programs.

(Btw, you might also want to try mintty, which has a more native UI than rxvt and which supports Unicode.)

share|improve this answer

The rxvt shortcut that works for me is

Target: C:\cygwin\bin\rxvt.exe -display :0 -fn "Lucida Console-14" -tn rxvt-cygwin-native -e /bin/bash --login

Start In: C:\cygwin\bin

Can you see if this works?

share|improve this answer
    
That shortcut will also open briefly and then just shut down. I have tried just open rxvt.exe clean from bin\ now to see if it could be some problem with the .exe file, and it works. It also works when executing rxvt from cygwin. –  starcorn Jan 6 '11 at 16:00
    
it works now, I just had to remove the last bit Start In: C:\cygwin\bin –  starcorn Jan 6 '11 at 16:08
    
Does it really need the -display :0? I thought rxvt's point was to not use X. –  Rich Homolka Jan 6 '11 at 16:47
    
Hi @Rich, it doesn't use X. the -tn rxvt-cygwin-native means that it runs as a Windows GUI app. I'm not sure if the display command is necessary, but it is on the native mode shortcut that gets created when you install rxvt, and that shortcut has worked for me, so I posted it as-is, going on the assumption that the rxvt install script knows better than I. –  dsolimano Jan 6 '11 at 18:48
    
Hey @dsolimano, I don't think the -tn does what you think it does. It merely sets the TERM env var to rxvt-cygwin-native. If it works for you, it works :) –  Rich Homolka Jan 6 '11 at 19:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.