Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using tortoise svn for a couple weeks now.

I get errors very often. Almost everything I do creates an error. this is with repositories on the internet, locally on my machine or a machine on the network. So I started to keep track. Some examples are below.

12/31/2010

Can't move 'C:\Users\jisaacks\Desktop\my branch test.svn\tmp\entries' to 'C:\Users\jisaacks\Desktop\my branch test.svn\entries': The file or directory is corrupted and unreadable.

01/04/2011

Commit failed (details follow): Server sent unexpected return value (405 Method Not Allowed) in response to MKCOL request for '/svn/kranichs-svn/!svn/wrk/b316f15e-0869-4644-9c53-87aa0103506b/branches'

01/06/2011

Can't move 'C:\Users\jisaacks\Desktop\DVD Catalog\vendors.svn\tmp\entries' to 'C:\Users\jisaacks\Desktop\DVD Catalog\vendors.svn\entries': The file or directory is corrupted and unreadable.

01/06/2011

Can't move 'C:\Users\jisaacks\Desktop\DVD Catalog\cake\tests\test_app\views\layouts.svn\tmp\entries' to 'C:\Users\jisaacks\Desktop\DVD Catalog\cake\tests\test_app\views\layouts.svn\entries': The file or directory is corrupted and unreadable.

01/06/2011

Commit failed (details follow): attempt to write a readonly database attempt to write a readonly database

That last one about the read only database happens every time I commit. Say if I am working on the head revision (7) in a working copy. I make a change and commit it. It gives me this error. But if I look at the log it tells me that there is now a revision 8 (the commit I just made) but I am still on revision 7. So I need to run update to be on the current revision that I just commited. I hope I explained that clearly.

Anyways with all these errors I wonder.. Is TSVN just this unstable, does everyone have these issues. Or is it just me? If just me, what could I be doing wrong?

share|improve this question
    
What is giving you the copy errors? It sounds like Windows, not Tortoise. If the server is giving you errors (405, writing to a read-only db), there might be something wrong with it. – Nick T Jan 6 '11 at 21:47
1  
Are you running Win7? From a ServerFault question, apparently Windows 7 has problems copying svn directories. The fix was released a while ago; are you updated? – Nick T Jan 6 '11 at 21:49
    
@Nick yes I am on win7 I will update my version of TSVN and see if that helps. Thanks. – JD Isaacks Jan 6 '11 at 21:56
    
@Nick I updated my version of TSVN, I am not getting the error when I commit tho, however I still need to update after a commit to be on the current Revision I just created. – JD Isaacks Jan 7 '11 at 15:02

I have seen this problem on a colleague's PC, it turned out that it was Microsoft Security Essentials corrupting the files downloaded by TortoiseSVN. As soon as we disabled it, the problem disappeared and the SVN checkout was fine.

I suggest to temporarily disable your antivirus and try again.

share|improve this answer
    
I will try this next week when our system admin is back in the office. Thanks – JD Isaacks Jan 7 '11 at 15:03

Today I also got the following error:

svn: E200031: attempt to write a readonly database

The solution (found here) was to go to the svn server and and fix the permissions of rep-cache.db in the project's db folder (e.g. /svn/my_project/db/rep-cache.db)

Note that rep-cache.db was hidden from a regular ls but was exposed in FileZilla.

The following 2 commands solved the problem:

sudo chown root:root rep-cache.db
sudo chmod 777 rep-cache.db

Note that these are not safe permissions, but they did the trick.

Interestingly enough the file rep-cache.db does not seem to exist in our other projects.

share|improve this answer
    
Thank you! Got this same strange error today with a seldom used repo. The rep-cache.db file was owned by root:apache instead of apache:apache. I changed the owner only (not permissions), and the problem went away. Interestingly, we could commit empty, zero-byte files, but files with any content were blocked with the "readyonly database" error. – Mac Jan 9 '13 at 20:29

I faced the same issue. After some searching on the internet found this article. Then realized that I was logged as a user different from the user that I had used to setup svn under, a permission issue basically.

Update: Adding more information so the answer is complete without the article too.

Basically, I had setup/installed the svn using root user and the default user on many linux systems is other than root. So when I logged into the system I was not root, hence I was getting the above issue. sudo su, was required to login as root and everything worked

share|improve this answer
1  
Can you summarize that link, so that if it goes dead, your answer is still useful? – John Bensin Oct 11 '13 at 13:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .