Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently introduced a new machine to my LAN. The computer name for this machine is 'server'. Historically I've been able to access machines from my home network (from a web browser or RDP) using the machine name and it resolves to a local IP address just fine. However, I can't seem to do this anymore.

When I ping the computer name, I get the following:

C:\Users\Robert>ping server

Pinging server.router [67.215.65.132] with 32 bytes of data:
Reply from 67.215.65.132: bytes=32 time=24ms TTL=54
Reply from 67.215.65.132: bytes=32 time=23ms TTL=54
Reply from 67.215.65.132: bytes=32 time=24ms TTL=54
Reply from 67.215.65.132: bytes=32 time=24ms TTL=54

I notice also that it appends the 'router' suffix to my domain name for some reason. 'router' is the name of my router, obviously. I'm also using OpenDNS as my DNS provider (configured through my router so it gets passed down through DHCP).

Why is this not working for me? Can someone explain how the DNS resolution should take place? For LAN resolution, it shouldn't go straight to OpenDNS. I thought that each Windows machine kept it's own sort of "mini DNS server" that knows about all machines on the local network and it first tries to resolve using that.

Please let me know what I can do to get this working!

share|improve this question
    
Is this machine a Windows Server? Is it running DNS? –  John T Jan 7 '11 at 1:24

2 Answers 2

up vote 0 down vote accepted

There is a DNS cache, but that relies on actually having DNS servers to query, otherwise it's other caches that handle it.

There's a good chance that you have the other names in hosts, lmhosts, or you were using NetBT resolution and you've turned that off now. Check how NetBT is configured in the WINS tab of Advanced Configuration on the IP interface; if it's disabled, that might be your answer. If that's the case, it'll rely exclusively on DNS, in this case OpenDNS.

If you have no static lmhosts, NetBT service might also be disabled or firewalled off on one or both hosts. You could check that by trying to browse shared files with \\[ip] in Windows Explorer.

There's an outside chance that your router is misconfigured and routing your NetBT broadcast out to the public interface, but that shouldn't work at all unless it's been seriously tinkered with.

share|improve this answer
    
I'm accepting this as the answer because it reminded me that I had NetBIOS announcement disabled in my router's firmware. Thank you! –  Robert Dailey Jan 7 '11 at 4:32

Has your router got the name 'server'? You could test this by renaming your new computer 'servertest' and then seeing if you can ping that correctly by name. Also, have you put the new computer in a DMZ or used no-NAT in the router's setup?

share|improve this answer
    
The router is named 'router'. I can't ping other computers by name either. For example, another computer on my network is named 'bob', and when I ping it I get an IPv6 address. –  Robert Dailey Jan 7 '11 at 4:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.