Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hey I been bugging with this problem for some hours now. And I couldn't find the answer on google so I try it here.

The problem is that when I run emacs in cygwin in -nw mode characters like åäö doesn't come out normally. However it is perfectly normal when I type those character in mintty terminal. The answer that I found on google is that I should type M-x standard-display-european however emacs doesn't have that option. It only found standard-display-cyrillic-translit

share|improve this question
    
What exactly does go wrong with those characters? Does it affect newly created files or existing files? –  ak2 Jan 7 '11 at 10:43
    
And which Cygwin version are you using? (uname -r will tell you.) –  ak2 Jan 7 '11 at 11:55
    
@ak - i'm using 1.7.x. Those character will show up as blocks. It will show as blocks when I use cat as well. –  starcorn Jan 7 '11 at 12:32
2  
Hmm. Where are you running emacs? In mintty or in the default console? If the latter, try choosing a TrueType font such as Lucida Console in the console properties. –  ak2 Jan 7 '11 at 13:18
1  
That looks like inconsistent charset settings then. What are locale and character set on the Text page of mintty's options set to, and what are the values of the LC_ALL, LC_CTYPE, and LANG environment variables? Are you setting those variables in bash startup files? If so, don't, because the terminal won't get to know about it. –  ak2 Jan 7 '11 at 16:00
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.