Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use my computer behind a router. My MSN program can connect to the Internet, but I can not open any web site with my web browser. It seems that this problem is related to DNS because when I input an IP address directly in the address bar of my web browser, the web page can be displayed. However, I don't know how to fix this problem. I choose Google Public DNS server on my computer, this problem still exists. My OS is windows XP. How to fix this problem? Any ideas?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

There are a few things to try.

  1. If you have a strict firewall / Ougoing rules, make sure that DNS requests are allowed.
  2. Remove the Google DNS settings from your computer, or check that they are correct.
  3. Set the DNS of your computer to the IP of your router and set Google as the DNS provider on the router.

I hope this helps, if it doesn't, can you please go to a command prompt and type ipconfig /all and paste that log in to your question.

share|improve this answer
    
My flatmate can open web pages on his computer. We share the same router. –  Steven Jan 7 '11 at 14:05
    
@Steven - which shows that it sounds like the problem is to do with point 1 or 2 of my answer... it could be any of three items I said. –  William Hilsum Jan 7 '11 at 14:34
    
My big-number ports are blocked on the router. –  Steven Jan 10 '11 at 13:51

Have you removed any viruses lately that were removed?

If so, check your Proxy settings under internet options, network, proxy if it is filled in and you DON'T use a proxy then remove it, if you do use a proxy ensure that this is your correct one.

Newer threats add a lovely proxy into the mix to generate revenue from clicks through bogus searches.

share|improve this answer

Check to make sure that you hosts file looks correct. It will be located here: %SystemRoot%\system32\drivers\etc\hosts.txt

It should look similar to the following.

127.0.0.1 localhost loopback

::1 localhost

For more information about the hosts file, refer to this webpage.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.