Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to associate custom icons to files on a fileshare for everyone (Windows). It works great for me and I can see the custom icons but if someone else opens the network folder he can not see the icons.

Is there a way to set the icons for everyone?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Other users don't see the icon because they cannot access the actual .ico file by using the same path as you do. For example, if you use an icon located in C:\Icons\Porn folder.ico, that path would be stored in a file named desktop.ini. When a network user opens the share, his system looks for the user's C:\Icons\, not yours.

To get around this, edit desktop.ini to contain a path that would work over the network - which means the .ico file must also be in a publicly-accessible share. If you kept the icons in a share named "Public stuff" and the computer was named florianpc, it would be:

[.ShellClassInfo]
IconFile=\\florianpc\Public stuff\Icons\Music.ico

But this won't work 100% (maybe 98%). It would be even better if you used a path relative to the folder. For example, this would make Windows look for a folder.ico directly in the folder itself:

IconFile=folder.ico

(By the way, Windows actually does this for folder.jpg in thumbnail mode.)

Similarly, this would make Windows go one level up, then look inside "Icons" directory:

IconFile=..\Icons\Music.ico

The desktop.ini file usually has both "Hidden" and "System" bits set, so you won't see it until you disable "Hide protected operating system files".

Alternatively, just open Notepad, click File -> Open, browse to the folder, and enter desktop.ini as name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.