Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Windows XP. I'm RDPing to a Windows 7 machine. I can cut and copy (ctrl-X or edit menu or right-click menu in various applications), but pasting just pastes nothing. (Regardless of if I paste by right-click or keyboard short-cut or right-click menu.)

Now what?

I tried shutting down and re-running rdpclip.exe, but it didn't help.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

sometimes clipboard doesn't work for me too. Sometimes complains - no enough memory, sometimes not.

When close some programs (inside RDP) to release memory - starts working.

share|improve this answer
    
Brilliant. I closed some extra IDEs I had open (eep) and then it started pasting. –  ashes999 Jan 7 '11 at 20:25
add comment

It seems siily but check to see if the clipboard checkbox is checked on the local resources tab??

share|improve this answer
add comment

Check if you have some software, that hooks the clipboard, running. For example, I have TypePilot and it stops working properly if RDP session is running (the opposite scenario to yours). MS Office, IIRC, has some clipboard extension tool, which can conflict with RDP. There's plenty of other stuff listening for clipboard events. If one of those listeners is written incorrectly and it doesn't pass notifications further, RDP clipboard monitor just won't know that clipboard has anything to paste.

share|improve this answer
    
As far as I can tell, there's nothing that's listening for the clipboard. How would I verify this? –  ashes999 Jan 7 '11 at 20:10
    
@ashes999 try booting in Safe Mode with Network Support and RDP from there. Safe mode will exclude almost all autostart applications from being autostarted, so you will know if that is one of the applications that cause the problem. –  Eugene Mayevski 'EldoS Corp Jan 7 '11 at 20:12
    
It's possible that my Delphi IDE or my SQLYog did it (killing them made it work). +1 for the right direction, but ultimately not the solution :) –  ashes999 Jan 7 '11 at 20:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.