Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just did a clean install of Win7 x64. I have a Microsoft Ergo Keyboard 4000 and use the calculator key a lot.

Previously, in Windows XP, I could hit it and get multiple copies of calculator to popup. Now it will only show one copy of calculator. I tried adding a shortcut to the calculator app but it has the same limitation. However if I click the calculator icon it will open a new one each time.

How can I fix this so each time I press the calculator key it will open a new copy?

share|improve this question

6 Answers 6

up vote 3 down vote accepted

Finally figured out a solution!

UPDATE 2014

This has been tested on Windows 8 and 8.1 and works.

Using a VBS file will make the calculator instance keep focus.

Dim oShell
Set oShell = WScript.CreateObject ("WScript.Shell")
oShell.run "C:\Windows\System32\calc.exe", 0, False
Set oShell = Nothing

Just create a text file like calculator.vbs and copy/paste the above code and double click or link the file to your keyboard button.


[ORIGINAL ANSWER]

Hopefully this isn't specific to a version of IntelliType. However I'm using IntelliType 8.2 x64 for Windows 7 with my Natural Ergonomic Keyboard 4000.

Once you have installed IntelliType go to Control Panel -> Keyboard then Key Settings tab.

Find the Calculator button in the Key Name column and click Configure. It will be defaulted to "Starts Calculator" now choose "Start a program, Web page, or file" and locate your copy of calc.exe which should be in your system32 folder. In my case it's "C:\Windows\System32\calc.exe"

Click "Finish" and it's now assigned and working as it did on previous Windows.

Now when you click the calculator button it will open multiple calculators instead of just bringing focus to an existing one.

As part of owning a business I do most of the bookkeeping. And having the ability to rapidly open multiple calculators with the calc button is great!

share|improve this answer

I just pinned the Calculator to the taskbar, then I right clicked and clicked on Calculator and it will open as many instances of the calculator that I want!

share|improve this answer

I'm afraid I don't have the perfect answer for you. However, once you have opened the first instance of Calculator in Windows 7 it will appear on the taskbar. If you then hold shift and then click the calculator icon on the taskbar, it will open a new instance. (You could try shift + your calculator key, but I don't think that will work)

share|improve this answer
    
yep I read that as well. I was looking to restore the original functionality of the calc key in XP and even a previous "Beta" copy of Win7. thanks for the tip though. –  Brian Boatright Jan 7 '11 at 21:45

This is a known problem with no definite known solution, although he stated that installing the keyboard driver after any other interface drivers helped.

share|improve this answer

I have a microsoft keyboard also. The problem only occurs for me when I install the software for the keyboard. Uninstall the software and it works fine for multiple calculators again. Happened under XP and 7.

share|improve this answer
1  
For me it would happen regardless if I installed IntelliType. Are you using a Natural Ergonomic Keyboard 4000? I finally figured out a work around and posted my solution. –  Brian Boatright Nov 15 '11 at 2:02

Finally figured out a solution!

Look and find this version of (Intellitype--//--ITPx64_1033_8.20.469.0.exe).

Uninstall the current Intelli-type, and install the one you just have downloaded.

Once you have installed IntelliType go to Control Panel -> Keyboard then Key Settings tab.

Find the Calculator button in the Key Name column and click Configure. It will be defaulted to “Starts Calculator” now choose “Start a program, Web page, or file” and locate your copy of calc.exe which should be in your system32 folder. In my case it’s “C:\Windows\System32\calc.exe”

Click “Finish” and it’s now assigned and working as it did on previous Windows.

share|improve this answer
1  
What's up with copying almost all of Brian's answer? It seems only the 2nd and 3rd lines are your own? –  Arjan May 2 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.