Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since I installed Outlook 2010 on a new machine (WinXP Pro SP3) a couple months back I have had an issue that is quite annoying: If I close Outlook then attempt to restart it I get a small pop-up saying only: "Cannot start Microsoft Outlook". I found one workaround, but not a terribly practical one: reboot. If I reboot then launch Outlook, it opens fine.

Here is what I know:

  • Since I can run Outlook just fine after a reboot, I do not see that a system restore, an OS reinstall, or the like would help.
  • I tried "outlook.exe /resetnavpane" and "outlook.exe /safe" but those give the same error.
  • There are no entries in the event log.
  • There is no instance of Outlook appearing in the process list once I close the program, so it does not seem to be an alias for "outlook is already running".

As far as I have found, my situation is unique among reports of similar incidents: I have uncovered no other reports saying Outlook would run fine the first launch or that a reboot would again allow it to run.

Suggestions?

share|improve this question
    
Can you use Process Explorer from Sysinternals, use find->Handle or DLL, and search for .pst (or .ost if you're on Exchange)? That might pinpoint something. –  SilverbackNet Jan 8 '11 at 0:01
add comment

2 Answers

up vote 1 down vote accepted

Have you tried deleting and recreating your mail profile? I have found that wily Outlook startup bugs can be resolved by doing this. Note that you will have to set your files and mail servers up again, but you should not lose any data.

Instructions are here: http://office.microsoft.com/en-us/outlook-help/remove-an-outlook-e-mail-profile-HP001230477.aspx

share|improve this answer
add comment

I am giving credit for the answer to Mafuba because his suggestion is ultimately correct. I am adding my own answer here, though, to provide details in case other folks may not be as familiar with what he suggested ( which included me :-) along with my own suggestions for getting the best result.

Caveat #1: Before you do anything, backup the registry settings for Outlook so you can start again if you need to! This microsoft forum post (Outlook wont run up, mail control panel applet says I have run out of resources) identified the registry path: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem

Caveat #2: Before you delete a profile make sure you write down its details so you can apply them to a new one! Open the Mail control panel, select profiles, then examine the settings for such things as your email address, your exchange server, your data file locations, and so forth. When you create a new profile Outlook can automagically determine all of these... except when it cannot (see below).

Issues I ran into:

Could not open the Mail control panel; received the error "Your system needs more memory or system resources. Close some windows and try again." Thinking that since I was having an issue with doing something with Outlook the second time, I thought that if I tried the control panel right after a fresh boot, it might open, and it did!

At one point I then began to create a new profile using the Auto Account Setup process but quickly ran into this error "An unknown error occurred, error code: 0x80070057". The workarounds for that, according to this microsoft forum post Error 0x80070057 occurs when you create an Outlook 2010 profile by using the Auto Account Setup process for an Exchange 2003 mailbox, included doing it manually--which is why I suggested recording the settings from the old profile above.

But since the automatic setup did not work, I decided to try one more thing before creating a new profile manually: in the mail control panel I just made a copy of my suspect profile, thinking the copy process might be cleansing as is often the case. Turns out this worked fine. When I started Outlook, it prompted me for which of the two profiles I wanted to use. I selected my new, copied profile and it opened fine. I closed Outlook and re-opened it and it again opened fine! Also, I could still open the mail control panel; no more errors there. My final step, then was to delete the corrupt profile, and finally do a reboot. Then a couple more checks to make sure I could open and re-open both Outlook and the mail control panel showed everything was now working the way it should.

To sum up:

I would amend Mafuba's suggestion just a bit: rather than delete your profile then recreate a new one, I would try to copy it first. If copying does not work, I would do a create-then-delete rather than a delete-then-create, just in case you need to get some information from it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.