Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a new Windows 7 machine, and was using VNC, SSH etc to connect to my Ubuntu machine, and it worked fine previously connecting to the Ubuntu computer's hostname. Now it doesn't work if I use the machine's hostname, but it does if I use the local IP or DynDNS name. I can also access it from my Android phone using the local hostname over SSH.

If I try to connect with SSH to the hostname, it says "Host does not exist". VNC says "Failed to get server address". NX says "no address associated with name", and I don't see it in Windows' "Network" folder.

I've rebooted everything. I've turned off Windows firewall. It was working fine a few days ago, but now it's not. How do I figure out what's blocking it?

Aha: It probably has something to do with Samba. I reset the Samba configuration the other day, and apparently this can affect it. http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=1558925 I tried commenting out "encrypt passwords = No" as described there, but it still doesn't work.

share|improve this question
add comment

2 Answers

You can always install Bonjour on the windows computer with Avahi complementing it on the Ubuntu machine. On the ubuntu, go to desktop sharing (or something like that, I'm blanking right now) in the admin menu. Bonjour is available from the Apple website.

They're both a sort of local DNS server. It'll give the computer a [computer name].local address, and route all things through it. Make sure you have UPnP (Universal Plug and Play) enabled on your router.

share|improve this answer
add comment

Make sure the nmbd component of Samba is running – it deals with NBNS name resolution and network browsing – and that both machines have ports 137/udp, 445/tcp and 139/tcp open.

Also check if browsing is enabled in Windows; I think Win7 has an option to disable it somewhere.

(No, this is not related to "encrypt passwords". Do not set that option to "no".)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.