Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Vista Ultimate 32 bit Windows 7 Ultimate 64 bit

I've read through similar questions about sharing between Win7 and Vista, but none of them have resolved my issue of not being able to share between Win7 and Vista:

Previously
I had previously had my Vista and XP system sharing back and forth without any problems. I was able to access the shares without entering a user name / password in the NT challenge prompt (note: account names and passwords were different on the Vista and XP systems).

Currently
I replaced my XP system with a Win7 system. Now, when I attempt to access shares to/from Vista / Win7, I am continually prompted with an NT challenge to enter my credentials.

Things I've Verified/Tried

  • Both systems are on the same workgroup.
  • Win 7 is using the Home network. Vista is using the Private network. In other words, neither system is using a Public network profile.
  • Enabled file sharing with and without password protection on both Vista and Win7
  • Tried HomeGroup Connections (win7) with Windows to manage connections and Use user accounts to connect.
  • Reviewed too many online articles to count to trouble shoot.
  • Set the shares to have full control by everyone.
  • Set up the shares directly on the directory and through the share manager.

My Question
How can I enable file sharing between Vista and Win7 without being prompted with a username/password challenge, ever?

Edit
I just fired up a laptop (on the same workgroup) with win7 Ultimate 32-bit and the laptop had no issues sharing to/from the Vista machine and Laptop (win7). And the 2 win7 machines have no issues sharing.

For the life of me, I cannot see any differences in the settings that the laptop (win7 32bit) has and my other system (win7 64bit).

What is it about this one win7 that will not play nicely with Vista? Any ideas would be greatly appreciated!

share|improve this question

3 Answers 3

Type 'advanced share settings' into the Start button.

Turn on network discovery

Turn on file and printer sharing

Turn on public folder sharing

Turn off password protected sharing

share|improve this answer
    
All of the above is already set. I've tried disabling firewalls. And rebooting all the machines as well. There's some other setting that's being missed. –  Metro Smurf Jan 8 '11 at 17:38

Try that (it functions for Windows XP - sorry if I misspelled some words, because my source is in Portuguese and I tested only in Portuguese Windows versions):

step 1. start > execute > secpol.msc > security settings > local directives > security options > on right side "Network access: Sharing and security template for local accounts" > if current is guest, change it to classic

step 2. start > execute > secpol.msc > security settings > local directives > assignment of user rights > access to this computer by network > select: give access to all incuding to all from another computer

The source of that trick suggests to do steps 3 and 4, but I never done that and all is ok on computers I configure (I think step 4 is in the network adapter configurations).

step 3. start > execute > secpol.msc > security settings > local directives > assignment of user rights > deny local logon > remove guest account

step 4. Finally, enable NetBIOS for TCP/IP in the computers

Source: http://www.babooforum.com.br/forum/index.php?/topic/321898-conta-convidado-desativada-problemas-acesso-pastas-compartilhadas/

share|improve this answer

I was having a ton of problems sharing between Vista and Windows 7. I finally discovered that while my Sharing settings were all correct, my Security settings on Windows 7 were too restrictive for the folder I was trying to share.

I had to go to Properties -> Security tab -> and add "Everyone" with full control in order for my sharing with "Everyone" to work.

Obviously giving "Everyone" full control is not an ideal case long-term and you can certainly give specific users access instead, but this was what I needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.