Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Windows XP on my machine (Company CQ5020NL). Before I was able to do that, I set the SATA controller to IDE in the bios.

Now I want to install Windows 7 upgrade. The DVD boots into the installation setup, but when I click "Install now" and am asked to load "A required CD/DVD drive device".

When I click "Browse" I can browse the installation dvd and the drive I want to install to.

I have tried all the SATA options in the bios already.

I have no idea what to do... can anybody help me out?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Usual causes are: Most likely to least likely

  1. Source file used to burn the disc was corrupt

  2. A corrupt burn of the disc

  3. Damaged disc from supplier

Solutions:

Download the file again and burn another one.

Re burn the disc with the same source file, maybe on different media and burner.

Purchase a new disc.

.

Some have reported installing the image to a USB flash drive using this tool and install by booting from the flash drive solved the issue also.

share|improve this answer

If this is an upgrade dvd, and since you are booting off it, are you sure it isn't just asking you for the original Operating System disk (ie XP), to prove that you are indeed upgrading a machine and not installing on a new System?

share|improve this answer
    
I can browse the HD with the Win XP installation, I think that's not the problem. Right now I guess the DVD was bad. I am creating a bootable USB drive right now. –  koen Jan 8 '11 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.