Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After reinstalling my Mac OS X 10.6.6 typing special characters like these " ~ and more does not directly insert them into the text, but waits for the next character to be pressed. If these two combines well, such as the quote and a to ä, they mix together. I find this very annoying. Is here any way to fix this, so the characters are inserted immediately? Thanks

share|improve this question
    
Have you checked what language your keyboard is set to? This is standard on Swedish keyboards, for example. – victoriah Jan 8 '11 at 23:03
    
Typing space after this symbols will print just the symbol, but I'd go down @victoriah's route: check your locale settings. – Nerdling Jan 8 '11 at 23:13
    
@victoriah this happens both for Input Source US International and my national language. Formats are set to United States (Computer). @Nerdling I know, but it's slowing me down too much. – Mikulas Dite Jan 8 '11 at 23:22
up vote 1 down vote accepted

This is "dead keys", though MacOS calls it something else. On both *nix and MacOS, it's triggered by choosing an international keyboard layout.

Go to "System Preferences", "Language & Text", select the US keyboard layout and unselect the "US International - PC" layout.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .