Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a local security policy setting or somesuch to allow limited user accounts to modify the contents of USB drives?

Currently I get an "Access denied" error, further saying "Make sure the disk is not full or write-protected and that the file is not currently in use."

The Administrator account has no such obstacles.

Update: The problem is at least solvable by altering NTFS permissions (granting Full Control to Users), and therefore I'm losing hope that there is a more global solution.

share|improve this question

1 Answer 1

Have you tested this usb device with another computer? because some usbs after a while stop allowing write access or stop completly working at all. If thats not the case maybe it is a policy set wrong, to fix it open the Registry Editor click on the Start button on your taskbar, then click on Run and type “regedit” and click on OK to start the regedit utility.

Expand HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control.

From there right click and create a new key and name it “StorageDevicePolicies”. In the window on the right then create a new DWORD value and label it WriteProtect, give it a value of “1″ and users can no longer write to USB drives. To re-enable this option change the value to 0 and users are again allowed to write.

share|improve this answer
    
That did not make any difference. I think my issue is one with NTFS permissions. Which is a shame because it will need to be rectified for every USB drive I use. –  Quick Joe Smith Jan 9 '11 at 1:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.