Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For about a week I've been having trouble accessing a website I frequently visit from my laptop in my apartment. (The domain is if it matters.) Symptoms are as follows:

  • Whenever I try to access the site normally (i.e. in a browser) the connection times out.
  • Trying to resolve the site name on DNS using dig +showsearch +trace ends with the message "connection timed out; no servers could be reached". dig is able to retrieve the NS records for the domain, which specify the nameservers ( and ( It times out trying to connect to either of those servers.
  • The IP address for is, and attempts to ping that IP address are unsuccessful. The connection times out.
  • When running traceroute the trace reaches up to ( (step 21) with no problems or delays, and then I get just * * * after that.

So far it just sounds like the server is down. But here's the weird thing: I have no problems accessing from any other computer. I also have no problems accessing any other websites from my laptop. As far as I can tell, it's only the one particular combination of my laptop in my apartment and this one website that is causing problems. (I haven't tried taking my laptop elsewhere, but that's probably next on my list)

What sort of diagnostics can/should I run to try to figure out what's going on here? As mentioned, I've already tried ping, traceroute, and dig, and I've also fired up Wireshark during all three of these to see if it showed anything useful, but I haven't seen anything that signals a problem to me. (I'm not the greatest networking expert, I could be missing something) Is there anything else to do?

As the tags suggest, I primarily run Linux, but I do have Windows available to test with as well. (I have the same connectivity problems to the website when I'm running Windows, so it's not an operating-system-dependent problem.)

EDIT: The problem turned out to be that my IP address was blacklisted by the server's firewall. No idea how it got on the blacklist, but the site admin removed it and the connection works now. Anyway, even though my specific problem has been resolved, I'm still interested in any more suggestions as to tests I could have done to gather useful information.

share|improve this question
Can you ping and tracert from another computer? If you can't they are probably blocking ICMP, so throw those tests out the window. – MDMarra Aug 15 '09 at 3:08
I can't ping them -- I also get to Can't connect to the site at the moment either... – John Fouhy Aug 15 '09 at 3:32
@MarkM: yes, both work fine from another computer. Good point though. – David Z Aug 15 '09 at 15:34
Brilliant that it is solved! I can't believe how many admin's bulk block IPs because one or two people give them trouble! Glad my answer solved it for you! – William Hilsum Aug 15 '09 at 18:35
@Wil: Not that your answer wasn't a good one, but actually the problem was solved independently when someone at the host just decided to check the firewall. It had nothing to do with any of the answers here. – David Z Aug 17 '09 at 22:56
up vote 2 down vote accepted

Have you tried another computer in your house on the same internet connection (1), or your laptop on a different internet connection (2)?

I had a friend with the same issue and when he tried (1), he had the same problem and could not work out why when he took his laptop to my house, he could access a website.

I emailed the site administrator, and it turns out that he had blocked the entire IP range because someone was giving him problems.

You never know, it may be worth a try!

It could explain why DNS can resolve, but no connectivity. (just tried pinging from here and it worked)

If you have tried (2), ignore the above and I will give it another think!

Until then, if you need it urgently, try using a proxy server and see if you have any luck,

edit -- as well as that, it could be your ISP blocking it. If they have any forums, you may want to take a look. I know that I was trying to diagnose a similar problem for a good 2 days for a client and it turned out that the site was incorrectly placed on the IWF list (good in principal, rubbish in implementation), and the ISP was simply dropping all packets to the site without any warning. It got removed after I kicked up a fuss, but got no apology or explanation.

share|improve this answer
+1 good ideas, neither of which I had tried. (Also with the proxy server - that's actually just what I did) – David Z Aug 15 '09 at 15:36

Firstly, the server is reachable from where I try.

$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=52 time=312 ms
64 bytes from icmp_seq=1 ttl=52 time=296 ms
64 bytes from icmp_seq=2 ttl=52 time=296 ms
64 bytes from icmp_seq=3 ttl=52 time=296 ms
64 bytes from icmp_seq=4 ttl=52 time=296 ms

---- PING Statistics----
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip (ms)  min/avg/max/med = 296/299/312/296

Was able to complete a traceroute in 9 hops.

8   296 ms   296 ms   296 ms []
9   296 ms   296 ms   296 ms []

The site seems to have recently (July 29) changed from to

  1. Can you try the following lookup?
    dig @ -x
  2. Since changing the OS on the same laptop reproduces the problem,
    It is more likely to be on the network path beyond it.
    Some curious questions:
    • Does your external IP address change across the Linux and Winodws boot?
    • Do the other machines you use from the same point as your laptop have different IP addresses?
    • Do you have broadband/dialup connection that gives you a different IP address each time you login?
share|improve this answer
For your curious questions: (1) no, the external IP is the same (2) as I commented to Wil, I hadn't tried it from my other computer, but they would have had the same external IP (3) no, it's a building network that has one static IP address. Interesting questions though. (Also, as the problem is now solved I'm not sure what the result of the dig lookup would be but if it happens again I will try reverse DNS) – David Z Aug 15 '09 at 15:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.