Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I visit a page that isn't in my native language, how can I make Google Chrome translate it automatically for me into my native language?

Do I need to change any settings, if so where can I find them?

share|improve this question
3  
This is about Chrome not web apps –  Ivo Flipse Jan 9 '11 at 15:49
    
Related: superuser.com/questions/206019/… ( though this is for OS X) –  Sathya Jan 11 '11 at 11:47

3 Answers 3

When you visit a page in Chrome where the language doesn't match your locale, Chrome will prompt you to translate the page content:

screenshot

As you can see, my locale is English, and when I visit this page in French, Chrome offers to translate the content for me. When I click the Translate button, it will perform an inline translation of the content, and allow you to hover over a word or phrase and see the original content:

final translation

If this doesn't happen automatically, make sure that in Chrome's preferences, the option to automatically translate is selected.

preference

share|improve this answer
    
So you don't have to change any settings or download extensions? –  Ivo Flipse Jan 9 '11 at 15:59
    
@Ivo Fixed, thanks! –  squircle Jan 9 '11 at 16:03
    
@Ivo - no, you do not need to install any extensions. Just update Chrome settings if needed. –  Metro Smurf Jan 9 '11 at 17:33

If not done automatically, you can use this: Chrome Google Translate extension.

share|improve this answer

If you have already chosen "Don't translate this page", the prompt won't come up.

You can right-click and there should be a translation option available.

enter image description here

You may have to check the translation bar that drops down to make sure the source language is correct.

share|improve this answer
    
Chrome wasn't auto detecting a page as being in another language, so even though I hadn't disabled it it wasn't coming up. This context menu method worked, thanks! –  Hashbrown Sep 5 '13 at 5:04
    
Glad to necro-help :) –  Steve Sep 14 '13 at 2:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.