Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I set up my XBox 360 as a Windows Media Extender although I can see all the media I have on my Windows Vista PC it is excruciatingly slow to move between albums etc

Is there anything I can do to improve this or is it just because of the number of media files I have - about 5GB?

Cheers

share|improve this question
    
Interested in seeing if someone found a solution, since I have the same issue and could never find a workaround. –  Badaro Aug 6 '09 at 19:16
add comment

4 Answers 4

up vote 7 down vote accepted

By any chance, is your PC on a wireless connection? I have that setup and Media Center gives me exactly the same problem. When I actually get an audio or video file running it streams fine, but choosing menu items is agonizingly slow--it can take 30 seconds or more just to move from one menu item to another. It's a commonly reported issue.

Microsoft recommends connecting the PC directly to the router, but they say that the performance issues occur if both devices are wireless, and my 360 is wired directly to the router.

share|improve this answer
    
This is spot on, although like you my 360 is wired and my PC is wireless so doesn't quite match what MS are saying. I prefer to use last.fm now so not a big problem but if it becomes one then wired it will be... cheers –  David A Gibson Dec 8 '09 at 15:43
3  
I'm guessing you're both referring to the Media Center portion of the 360, as this is terribly slow for me as well. Meanwhile, with both my Xbox 360 and PC on wireless, streaming videos and music through the normal dashboard by sharing through Windows Media Player works perfect. –  Will Eddins Jan 6 '10 at 6:51
add comment

I am really disappointed that Windows 7 MCE is working so badly using XBOX-360 as a Media Centre Extender. Vista MCE, using exactly the same setup, worked well, but I am not keen to roll back.

When it is being slow there is no network traffic going over the wire. Surprisingly when I start streaming a live tv channel then the entire user interface suddenly comes back to life and behaves as expected and performs well.

Update: Disabling the sounds and animations in the extender settings seems to have solved the problem... for now. Would really like to see the pretty animations though ;-)

share|improve this answer
add comment

Are you using Wireless B or G? If so you'll want to switch to using either a 100MB LAN Cable or Wireless N. The reason is Wireless B and G really aren't fast enough for Media Center Extender to work at an optimal speed.

share|improve this answer
add comment

You could try Tversity to manage your media files for you. You install it on your Vista machine and it creates a Streaming Server that streams to your Xbox. I have had no issues at all with it and my media library is far bigger than 5GB.

share|improve this answer
    
If I can't find a fix for this then I'll definitely check it out, cheers –  David A Gibson Jul 16 '09 at 7:53
add comment

protected by Diago Feb 22 '11 at 19:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.