Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got a new magic mouse and the left and right click work fine but the swiping and scrolling wont work. I am running Snow Leopard (Version 10.6) on my 2009 MacBook and have performed all the updates. I have tried disconnecting and restarting the mouse and computer in all the combinations I can think of but still nothing.

share|improve this question
add comment

4 Answers

Have you enabled swiping and scrolling in System Preferences?

share|improve this answer
    
For some reason that preference doesn't show up when I open the preferences for the mouse. The only things it shows are the tracking speed, double click speed, and primary mouse button. –  Lindsay Montgomery Jan 9 '11 at 21:18
    
Did you install the drivers? –  bahamat Jan 9 '11 at 21:51
add comment

Ok problem solved. As it turns out I had to go to http://support.apple.com/downloads/ and go back and find all the Snow Leopard OSX updates and download versions 10.6.1 - 10.6.3. If you are having the same problem I was having you should know that just going to the apple symbol and then to Software Updates is not enough to update your system to support all the magic mouse functions.

share|improve this answer
add comment

I had the same problem because of a conflict with USB Overdrive. I thought it was uninstalled, but apparently I hadn't removed the kernel extension at /System/Library/Extensions/USBOverdrive.kext. Running the uninstaller fixed it.

share|improve this answer
add comment

I have an iMac with OSX 10.6.8. My problem was that the computer was recognizing the mouse as a Mighty Mouse and not a Magic Mouse and would not allow the scroll and swipe capabilities.

What I did to fix it was use the remote mouse app on my iPhone to control the computer while I disconnected and rediscovered the mouse and for some reason, after that, it is recognized as a Magic Mouse and has all of the necessary capabilities.

I assume this would work if a USB mouse was connected to accomplish the same fix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.