Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know if here is the right place to ask this question or not but its vital for me to solve it.

I run openSUSE 10.2 from VMWare on Vista. Yesterday I run VMWare and another program but both couldn't run and I end both tasks to solve it but now I can open VMWare without any problem and run another OS but not openSUSE. the error is:

Cannot open the disk 'C:\Users\hamide\Documents\Virtual Machines\SUSE Linux 2\SUSE Linux 2-000003.vmdk' or one of the snapshot disks it depends on. Reason: Failed to lock the file.

I don't have any backups.

share|improve this question

migrated from Jan 9 '11 at 23:38

This question came from our site for professional and enthusiast programmers.

Check out… It is a little old but I am sure if you google that error you will find something more up to date. – Jesse Jan 8 '11 at 3:40
Ask this on . – houbysoft Jan 8 '11 at 3:55
thanks a billion Jesse – bahar Jan 8 '11 at 4:05
Can you just copy the vmdk and re-attach the copy to your instance? – Xiè Jìléi Jan 10 '11 at 4:00

The answer (as posted in the link in the comment to the question, answered here for posterity) is to remove or rename the ".lck" file. Search for vmware KB "Investigating hosted virtual machine lock files".

share|improve this answer

You must log in to answer this question.