Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I can't use telnet to connect to any server but it works fine from a different computer. It just says it can't connect. I tried the following things:

  • Disable firewall and AV protection. (Basically, there was no security feature left online)
  • Telnet is set to "Trusted" in my AV protection. (Kaspersky Internet Security 2011)
  • Using Putty to telnet, but apparently Putty's connection is also inhibited. (Says it can't connect to host)
  • Disabling the telnet client in Control Panel and then re-enabling it. (Windows 7 Ultimate)
  • hosts file is clean.
  • Checked for nasties using MBAM and KIS 2011 as well as going though my HijackThis logs, nothing found.

I can connect to the same machines/servers through the web browser, ping, tracert, etc. Only telnet seems to be blocked.

Any other thoughts?

share|improve this question
can you reach it via other means from this machine (ping/ftp/tracert)? – Rhys Gibson Jan 10 '11 at 0:40
@Rhys Yes I can – BloodPhilia Jan 10 '11 at 0:41
Is your specific client blocked by the telnet server or is telnet running on a different port? – Rhys Gibson Jan 10 '11 at 0:55
@Rhys It works fine from machines operating within the same subnet and sharing the same external IP. Furthermore, it works neither with port 25 nor with custom ports. – BloodPhilia Jan 10 '11 at 0:59
Weird. So what's different about that machine/user account? Any default telnet settings that are different (does display return any differences)? If you start a telnet server can it telnet to itself? – Rhys Gibson Jan 10 '11 at 1:29

Have you tried disabling the auto-tuning diagnostic in Windows 7?

netsh int tcp set global autotuninglevel=disabled

Microsoft Support KB article:

When the receive window autotuning feature is enabled, older routers, older firewalls, and older operating systems that are incompatible with the receive window autotuning feature may sometimes cause slow data transfer or a loss of connectivity.

The default auto-tuning level is "normal", and the possible settings for the above command are:

  • disabled: uses a fixed value for the tcp receive window. Limits it to 64KB (limited at 65535).
  • highlyrestricted: allows the receive window to grow beyond its default value, very conservatively
  • restricted: somewhat restricted growth of the tcp receive window beyond its default value
  • normal: default value, allows the receive window to grow to accommodate most conditions
  • experimental: allows the receive window to grow to accommodate extreme scenarios (not recommended, it can degrade performance in common scenarios, only intended for research purposes. It enables RWIN values of over 16 MB)
share|improve this answer

Run Wireshark and see if the telnet command produces any traffic at all.

share|improve this answer

Sorry, I know you won't like this, but, I think it is your security software somehow, somewhere.

This really is not normal behaviour, and the fact that you said other machines on the same network can access means we have isolated it to your machine.

Something must be blocking it. Depending on how low level your firewall is, possibly try to enter safe mode with networking and see if you can connect to a target.

However, whether or not this works, I still think it is related to security software.

share|improve this answer
Nah, still the same when I uninstalled all my AV protection! :P I've basically given up on this one and waiting for my next reinstall of Windows... – BloodPhilia Jul 3 '11 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .