Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know if this is appropriate to ask it here in superuser.
Please, just route this to appropriate stackexchange site if found unrelevant.

Here's my scenario. I have bought a new motherboard (MSI 785GT-E63). I already have an old CRT monitor connected to it.
After I install a linux OS to it, my monitor will display that it is:

  • Out of frequency.
  • Current frequency is 89Hz. The operating output of my monitor is (around) 60-70Hz.

I would like to get this thing work. How can I let my CRT display properly?
I was thinking of lowering down video frequency output of my motherboard, but I can't find any settings on my BIOS setup.

Additional info:

  • My monitor is attached directly to the built-in video adaptor of my motherboard. (No additional video cards)
  • Install of OS is complete without errors.

Please help.

share|improve this question
up vote 2 down vote accepted

You're at the right place, but there are few thing which need to be considered.

First, there is a video card between motherboard itself and monitor, it's just integrated into motherboard.

Your problem (if I'm identifying it correctly) used to be common back in the old days, but is pretty rare now. X server controls your video card output and in its settings, monitor refresh rate is incorrectly set.

You didn't tell us which distribution of GNU/Linux you are using, so I can't provide you good instructions, but I can give you starting points.

I'll assume that you're using as your X server.

First check if your video card drivers are correctly installed. I don't have any experience with AMD/ATI on GNU/Linux, so I can't give you any tips. The driver installation procedure is very likely going to specific to your distribution.

First, try with one of the following commands. If one doesn't work, try next.

Xorg -configure 
sudo Xorg -configure

They should create a new xorg.conf file in which the problematic configuration is stored.

If that fails, you'll need to find your xorg.conf file and change it by hand. You should start looking in /etc/X11 , but exact location depends on your distribution.

Once you do find the file, have your monitor's manual nearby. In the file, you'll find things such as horizontal synchronization, vertical frequency and refresh rate. You need to set them correctly, using values provided in the manual.

Here are few results from Internet searches:

share|improve this answer
my OS is Debian. I'll be trying this when I go back home. I'll get back to you as soon as I have the results. Thanks. – Neilvert Noval Jan 10 '11 at 2:16
@Neilvert Noval OK. Which version of Debian? Latest? – AndrejaKo Jan 10 '11 at 2:21
2.xx. I think it's 2.68 or 2.86. (i must have mixed up 6 and 8) – Neilvert Noval Jan 10 '11 at 2:22
@Neilvert Noval Well, that's seriously old. Are you really really sure? Versions 2.xx were popular back in late 90s and early 00s. Also, I can't find any source that confirms that version 2.6 or 2.8 existed at all. Maybe you're using kernel version 2.6.xx? They are relatively new. – AndrejaKo Jan 10 '11 at 2:27
oops. my mistake. I think that's a kernel version 2.6.xx. I think i need to look back to my PC as to what debian version i have installed. – Neilvert Noval Jan 10 '11 at 2:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .