Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange case that I cannot install windows 7 or windows vista on my 3 year old PC.

The machine is an MSI K9NGM, with an AMD AM2 processor.

I have bought a new Samsung SATA drive to install Windows 7 on, so as to preserve my existing XP install which I intend to dual boot in the future.

However about half way through either a vista or w7 install (just after the mouse is shown for the first time, after the first restart) the machine will crash with a blue screen.

I have removed, reordered the memory in the machine, with no luck.

Does anyone have any experience of why this would happen with BOTH vista and w7 when everything is fine with XP?

share|improve this question
    
What is the STOP code on the bluescreen? –  ta.speot.is Jan 10 '11 at 12:21
    
Do you overclock? Try going into your BIOS and set recommended defaults. What condition is the install disc in? –  Jay_Booney Jan 10 '11 at 13:16
    
@Jay_Booney It wasn't overclocked no, and I made sure I went through the BIOS and re-set the defaults. I didn't go as far as flashing it though. –  Alan Whitelaw Jan 10 '11 at 15:39
add comment

2 Answers

up vote 0 down vote accepted

I have now solved this issue and in-order to tidy up this question I am answering with my findings.

The problem was narrowed down to the mother board, simply by substituting every other component in the computer (apart from the CPU, which I knew work as my original XP install would still boot), hard-drive, memory power supply.

Once I bought a new motherboard and installed my components into it I was able to complete the Windows 7 install.

An incompatible motherboard was the problem.

share|improve this answer
add comment

Try using GPartEd on the HDD. Download GPartED, burn it to a CD, then boot your computer it to it. Once you're in the program, delete the partitions. Windows will then rebuild the partition table during the install. I have seen issues similar to this many times because the partition table gets corrupted some how.

It would be very weird if this worked since it is new, but it is worth a try since I have had similar issues before and this fixed it.

share|improve this answer
    
This didn't fix the problem, +1 for a tool I will use again –  Alan Whitelaw Jan 10 '11 at 15:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.