Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to configure my wireless network on my laptop running Ubuntu 10.10 and am having a bit of difficulty. I am a complete Linux newb, but want to learn it, hence the reason I'm trying to set this up. Here's the vitals:

It is a Gateway 600 YG2 laptop. It was previously running Windows XP, but I installed Ubuntu 10.10 in place of it (not a dual boot, I removed XP altogether).

I have an old wireless card that I'm trying to resurrect. I haven't really used the card in a couple years, but it seems to still work, I just can't connect to my home's wireless network. The card is a Linksys WPC11 v2.5. When I plug it in, Ubuntu recognizes the network, but won't connect to it. My home network uses WPA encryption and the only connection type that Ubuntu's network manager is giving me is WEP and then it asks for a key -- I have no idea what that key should be.

So, basically, I'm asking, is there a way I can instead connect through WPA? I've tried creating a new connection in network manager, but that won't work, it keeps falling back to the WEP connection and asking me for a key. I have tried to install the XP driver using ndiswrapper but I don't know if that's working or not. Is there a way to tell if:

A) the card is working as it should B) the correct drivers are installed (again, I installed the XP one using ndiswrapper NET8180.INF, but I'm not sure what to do next)

Any help would be appreciated. Thank you.

share|improve this question

migrated from stackoverflow.com Jan 10 '11 at 16:02

This question came from our site for professional and enthusiast programmers.

1  
This question should probably be moved to ServerFault. –  jmort253 Jan 8 '11 at 22:47
    
@jmort253 I have voted that way. Hang tight sma, the question (and any answers) will be moved to the right place. –  Ninefingers Jan 8 '11 at 22:50
1  
Since this question is about running Ubuntu on a laptop, it doesn't belong on ServerFault. I'd recommend moving it to either unix.stackexchange.com or superuser.com –  Matthew Rankin Jan 8 '11 at 23:33
    
OK, sorry about that. Just let me know where its moved to. –  sma Jan 8 '11 at 23:56
    
I would temporarily remove the encryption and attempt to connect to the network in its open state and see if your wireless card is working properly that way and then continue troubleshooting from there. –  Mark S. Feb 29 '12 at 12:59

2 Answers 2

skip straight to the wpa_supplicant backend, use wpa_cli to control it, query the access point for information, set login/password info.

run help from within wpa_cli to retrieve a better list of supported commands than the manpage provides.

and before all, verify your wnic supports the encryption method you want to use in the first place.

check here for a quick heads up archwiki

share|improve this answer

It does not seem that your wireless card support WPA - the type that your home network is using?

If it does, then edit the connection in Nework Manager and then try to change the security type to WPA.

share|improve this answer
    
I've tried that also. That doesn't work either. My card is recognized, yet for some reason is not getting an IP address. –  sma Jan 10 '11 at 13:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.