Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, Ubuntu 10.04 thinks I do not have a connection to the internet, when yesterday I did. I have Windows XP installed via dual OS boot, and the internet connection works perfectly.

What's going on?

share|improve this question
    
Wired or wireless? –  Michael Jan 10 '11 at 17:19
    
Wired, I've checked all the connection, when I didn't need to as it works perfectly well when using XP partition on this computer. –  oshirowanen Jan 10 '11 at 17:48

2 Answers 2

up vote 0 down vote accepted

You might try running these commands on Ubuntu to see if they clear up the problem.

This command should reset the whole networking system on your system and automatically renew your IP Address and fetch DNS servers and the such from your router.

sudo /etc/init.d/networking restart

These two commands are helpful if you ever run into problems with your ethernet connection. The drop and restart your wired connection.

sudo ifdown eth0
sudo ifup eth0
share|improve this answer

was it a clean install you did yesterday? if so perhaps the kernel has updated during post-install updates.if so you might have to compile your drivers for your network interface against the new kernel. check akseli's answer to see if you have in interface functioning, if you dont you should download latest tarball module for your network card, ./configure make && make install

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.