Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried running DxDiag (DirectX diagnostics), and I noticed that my graphics card is set to the onboard one that comes with the Core i5 processor (some Intel HD stuff).

On my computer, I also have a dedicated graphics card (an Nvidia 310). No serious gaming stuff, I know - just for programming.

However, I would still love to know how to switch to that dedicated graphics card instead.

My laptop is an MSI CX720.

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

I figured it out.

I had to toggle my prepared graphics processor from the Nvidia control panel (pretty weird), and then it worked just fine. A reboot was required.

enter image description here

share|improve this answer
    
How did you do that 'toggle'? I can not do that, even can't disable onboard intel card in bios. I wanna use nvidia card, cos webgl doesn't work with intel. thanx, you if can help! –  Pengő Dzsó Dec 27 '11 at 18:59
    
I added a screenshot which shows where. –  Mathias Lykkegaard Lorenzen Apr 8 '12 at 10:50
    
Interesting. That it shows up in Windows means that the dedicated card is already enabled, but is being used as a secondary (try right-clicking the desktop and selecting Screen resolution; it should show both adapters, though you may first have to plug a monitor into both). –  Synetech Jun 27 '12 at 17:27
add comment

Check your BIOS.

You need to either:

  • Disable the on-board graphics, possibly by disabling any shared graphics memory (or setting allocation to automatic).

Or

  • Set the primary adapter to be the dedicated card, PCI-e x16 or similar (BIOS dependant).
share|improve this answer
    
How would I set the primary adapter to the dedicated card? Disabling my onboard graphics card just makes the screen go black. –  Mathias Lykkegaard Lorenzen Jan 10 '11 at 18:56
    
@Mathias - I have no idea what the settings in your BIOS are - almost every BIOS is slightly different. If you have a "peripherals" option I'd check in there for video or PCI or PCI-Express. Otherwise there could be a shared memory setting inside a memory config somewhere. –  DMA57361 Jan 10 '11 at 19:10
    
DMA57361 is correct. There is no standard for BIOS settings, even within the same mfg, and there are at least half-a-dozen ways to do this, so you really do have to check the manual for your own motherboard. –  Synetech Jun 27 '12 at 17:28
add comment

Just in case anyone else reading this is a massive idiot like me, one other way to prioritise a dedicated GPU over an onboard one, without having to worry about fiddling about with your BIOS etc, is to plug your monitor into the socket on the dedicated GPU rather than the one on the onboard graphics card.

Only took about an hour of mucking about with settings for me to spot that one!

share|improve this answer
1  
That's a good point. Many more modern video-adapters and motherboards will be able to detect when a monitor is plugged in or not and switch automatically. +1 for the easy trick. –  Synetech Jun 27 '12 at 17:25
add comment

Simply right click on the game icon and hover your pointer over "Run with graphics processor". You could choose from the options as "integrated graphics" and "High performance Nvidia Graphics". That works on windows 7. No need to look into BIOS.

share|improve this answer
    
But he's talking he wants to use it 24/7, and he wants a setting. This would work, but it may be annoying. If you can edit BIOS (not hard really, just push a certain key when computer is turning on and you just have to go through a menu with your keys) than BIOS is preferable. –  Annonomus Penguin Aug 3 '13 at 19:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.