Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am an OSX user, I have Snow Leopard 10.6.5 and an updated AirPort (version 5.5.2). I am trying to connect to my university's wireless network, but it has a 802.1x security that I am having trouble defining... Here there are instructions for connecting with Windows XP, Windows 7 and Linux. Can someone please instruct me what should I do to set up this network on my Mac?

I have had previous success in setting up this network, but I have no idea what I did that made it work. Since I updated my AirPort (to version 5.5.2) it worked only seldomly and very slowly... Before the update, even when it worked it never remembered my password.

Update:
I have already tried to create a new "location", removed all the 802.1x user profiles and all the remembered networks, and made sure the in the TCP/IP tab 'Configure IPv4' is set to "Using DHCP". I also moved /Library/Preferences/SystemConfiguration/preferences.plist to my desktop in attempt to force the system to create a new set of settings. Still I can define the connection to work.

share|improve this question
2  
You may have more luck contacting your university's helpdesk; they should provide you support. –  josh3736 Jan 10 '11 at 18:30
    
Your university has no user support for networking issues? –  Daniel Beck Jan 10 '11 at 19:00
    
They hardly know anything about linux; they surely don't know about OSX –  hizki Jan 10 '11 at 19:03
    
Give them a try - the worst they can say is 'no'. –  Scott Jan 10 '11 at 19:33
1  
OS X is also vastly more common than Linux for most helpdesk applications. –  Fomite Sep 22 '11 at 7:37
show 5 more comments

4 Answers

While I have to admit that my only experience with university 802.1X networks on OS X was pretty straight forwards (select network; what's your password?; works), that was on 10.4 and some time ago.

That said, here are some things you could try. Open up the 'Network' section of System Preferences. If you've not already, you may find it convenient to create a new "Location" for your university settings. Once you've done so, select AirPort and click the 'Advanced...' button.

In the advanced pane, first go to the AirPort tab and delete any university-related wireless networks (including the one you're trying to connect to). Next, go to the TCP/IP tab and make sure 'Configure IPv4' is set to "Using DHCP". Finally, in the 802.1X tab, delete any user profiles. Hit 'OK', then 'Apply'.

That should clean out any old or incorrect settings you might have. Once you've done that, try connecting to the wireless network again. From memory, it'll pop up and ask you for your 802.1X user name and password after a short delay. If it works, double check the settings in System Preferences (particularly the 'Always prompt for password' check box in the 802.1X tab of advanced) and check if you need to set up a proxy (this was a big sticking point on an earlier incarnation of our university's wireless set up).

As I said in the comments, do go and ask your university's help desk. You never know - you may be lucky and find someone who knows Macs from personal life or a previous job. Also ask around on university and/or student association forums/web boards/mailing lists/Facebook pages/wikis if they exist - you probably aren't the only Mac user on campus and one of the others may have cracked it already.

share|improve this answer
    
Thanks @Scott, but I tried, and as I thought they have no idea about Macs there... And I tried everything you said, and still I have internet only intermediately and it's very slow (it's not suppose to be). Any other ideas? –  hizki Jan 12 '11 at 8:18
    
Sorry if I'm asking the obvious, but you are in an area that has decent signal strength, aren't you? Other than that, I'm afraid there's nothing else I can think of other than trying to seek out other Mac users on the network and seeing if they can make any suggestions. –  Scott Jan 12 '11 at 9:12
    
I have compared my settings with other student Mac users. Everything looks the same... It must be something I already have cached in my system settings, or a password or certificate that's clashing with the new one I am trying to set... –  hizki Jan 16 '11 at 3:52
add comment

It looks like the system should do it automatically. I would use a new location in network preferences so that any settings can be turned off when on other networks. In network preferences, on the airport, click advanced, 802.1X tab, and remove any profiles that are there to force the system to create a new one. You should be able to connect to the network normally. I have also had a problem with being asked for the password again, but I think this is a network issue and not a computer issue.

share|improve this answer
    
Thanks @ughoavgfhw, but I tried, and as I thought they have no idea about Macs there... And I tried everything you said, and still I have internet only intermediately and it's very slow (it's not suppose to be). Any other ideas? –  hizki Jan 12 '11 at 8:18
    
Try moving the file /Library/Preferences/SystemConfiguration/preferences.plist to your desktop and removing the password in Keychain Access, then restarting. This will reset all network preferences. If it works, then you can delete the preferences.plist file. –  ughoavgfhw Jan 12 '11 at 18:51
    
Tried it... Still no good. Maybe I'm missing something fundemental here? Or maybe, considering it used to work, there are now settings saved somewhere in my system that mess up my connection and need to be removed? I tried reseting stuff and looking around... Couldn't find anything that worked... –  hizki Jan 15 '11 at 12:12
add comment

There are two issues that you should check. In the Network Settings, go into 'Advanced' and then hit the tab 'TCP/IP'. If the Configure IPv6 is set to 'Automatically' or 'Manually', you might try turning it 'off'.

To be honest, it does sound like a signal strength problem.

Via the Apple logo, bring up the 'About this mac' dialogue and go into 'More info'; this brings up the System Profiler. Click on the 'Airport' and check to see the strength of your wifi signal. If you are getting a signal of -70 dBm or higher (i.e. closer to -58 dBm), then your signal strength is fine. If however you see a lower dBm, of say -85 dBm, then this is below the range of a stable connection; below -70 dBm your Aiport will try to re-scan for a stronger connection - hence the connection loss.

Solution (unfortunately) is to move closer to your WAP transmitter.

share|improve this answer
add comment

You're overthinking this.

Just click the airport icon in your menubar and select the network, then type the password.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.