Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dual-core AMD with a GeForce 9500 card, and have been experiencing random lockups.

I haven't found a way to reproduce them, but the only thing that works is to power off - the machine is completely dead. I've talked to others who have the same problem - it seems be related to the combination of a dual-core AMD MB and an nVidia card. I had a similar problem with the on-board graphics (nVidia 7025) except that the screen would corrupt:

alt text

I would really like to determine the cause of this. Is there any way to turn on additional logging that might help determine the cause of this?

Update:

I installed Fedora 11, and it's doing the same thing: random freezes. I guess next step will be to try Win7 to see if it has the same issues.

share|improve this question
    
I guess, you have updated to the latest drivers (with synaptic)... nVidia on AMD boards seems to have a bad reputation generally. –  nik Aug 16 '09 at 3:49
    
I've tried a number of different drivers - 173, 180, 185 - with no real difference. They all seem to lock up at random. –  chris Aug 16 '09 at 10:19

4 Answers 4

up vote 1 down vote accepted

Sounds to me like you are experiencing the results of a bad piece of hardware. (since you claim the problem exists even in different OSs).

I have an AMD Dual-Core, Ubuntu 9.04 Desktop with a NVidia Gefore 8800 running Compiz and dual dvi monitors and have never, ever had a lock up like you are describing. This machine runs constantly.

Apparently I am not using the latest NVIDIA drivers. I am running version 180.44.

Edited to add the following suggestion as to how to go about isolating this failing hardware:

If this were my PC I would begin eliminating variables. Switch the video card out with any other one you have laying around. Does the problem go away? If yes, you found the culprit. If the computer continues to lockup in the same way with a totally different video card then you need to isolate a different piece of hardware. Keep in mind a video card may fail only when stressed which would indicate possibly bad cooling or even it being under powered. RAM is also something that can begin to fail over time and cause crashes.

FYI: A lot of computers will stress the CPU 100% when left in the BIOS screen. So as a CPU heat/stability test you could idle in the BIOS' health screen (the one that shows CPU temperature) and see if the computer gets overly hot or crashes there. If it does then I would suspect the CPU and/or its cooling. Are you overclocking anything?

share|improve this answer
    
I'm beginning to suspect that, because this morning it hung during the post. Thanks for the data point, though. –  chris Aug 28 '09 at 12:20
    
It turns out it was a bad motherboard. New one is installed, and so far so good. –  chris Sep 3 '09 at 1:08

I've got the same sort of setup with Ubuntu 9.04 on a quad core phenom with the onboard graphics. I found that the system performs 99% better when i disabled compiz. I know its a bummer but it has something to do with nVIdea's drivers for ubuntu. I still get freezes when playing back wmv files every once in a while, but it is till better.

share|improve this answer
    
I tried that, it still hung up. Performance is OK, other than the hanging. –  chris Aug 21 '09 at 22:01

Did you try running windows on your system. If you are getting similar issues in Windows then it could be almost certain that their is an Hardware issue.

share|improve this answer
    
I tried installing Fedora, and it still hangs so I may have to try Windows to see if it does the same thing. –  chris Aug 27 '09 at 1:24

I'm running Ubuntu Jaunty also on an AMD mobo with Nvidia 8100 built in graphics. I had screen freeze issues as well, but in my case it usually happened while browsing, and everything would freeze but the mouse cursor. The cursor would move around, but nothing would respond to my clicks, and desktop items that normally change, such as gkrellm netmonitors, cpu monitors, would freeze. The only answer was to power down and reboot.

My answer was (after rebooting) to do a full backup, then reinstall :(

That seems to have fixed it. I'm guessing I had enabled one too many Launchpad PPA repos (repos with the latest bleeding edge versions of software I use a lot) Probably I had messed up something in the X server or something. Wish I could give you a better answer instead of just sharing your pain!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.