Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 and have adjusted something which has caused all of my shortcuts and program icons to show the same program namely Adobe Reader and when I click on any of the icon or shortcuts they only open Adobe reader, I have reinstalled Windows 7 But this has made no change, I posted this question yesterday but apparently with not enough information I hope this is better and someone can help.

share|improve this question
add comment

3 Answers

It appears you managed to associate Windows shortcuts with Acrobat Reader. Here's how you can check:

Go to Control Panel, Programs and select "Associate a file type..." in the "Default programs" section. There, you scroll down to ".lnk" (in the "name" column) and see the current default is "Adobe Reader" or anything other than "Unknown Application" (that's how it should be).

If the former is the case, you're pretty screwed. There's two ways to recover from this issue:

You can try to restore the LNK handler to default state, but it's not fail-safe.

You can create a new user in the Control Panel. The issue should not persist to that user, since file associations made by one user don't affect other users. Keep in mind, though, that you'll have to transfer settings and files from your old user, so this involves some work.

Also, I don't think you performed a proper re-install (you have to boot from the Windows DVD and select "Custom install").

share|improve this answer
    
Thankyou for your help you are right I'm screwed I will try a custom install as I am not sure how to restore the LNK handler to default but you have been a great help thanks!!! –  PHILIP KIRK Jan 11 '11 at 23:12
    
Something else you could try: Create a new user and see if the problem persists if you log in with that user. (It's quite likely you only changed the file association in the context of your own Windows user) –  Tobias Plutat Jan 12 '11 at 9:18
    
Thanks I will try your suggestion –  PHILIP KIRK Jan 12 '11 at 11:00
    
If it reall helped, please mark the answer as "accepted". –  Tobias Plutat Jan 12 '11 at 11:22
    
Creating a new user account worked all I have to do now is transfer some of my old settings to the new account, thankyou for your help and everyone else for there suggestions as I'm new to this procedure I will type accepted hope this is ok –  PHILIP KIRK Jan 12 '11 at 12:11
show 2 more comments

I've had a friend of mine experience the same problem. The only way that I could think of was to right click on a file thats been affected, and click on Open With, then Choose Default Programme. Select the program that should open this program and then click on the checkbox that says "Always use the selected program to open this kind of file".

Sorry that I can't think of a quicker way, but this way will at least get you back up and running using the most important files in their respective programmes.

share|improve this answer
    
I have tried your suggestion but all it does is changes all the shortcuts and icons to that program and then that is all they open, it must be some other file that I have changed, but thankyou for your help. –  PHILIP KIRK Jan 11 '11 at 13:54
    
Have you tried a system restore? –  mickburkejnr Jan 11 '11 at 14:22
    
I have tried a system restore but it refuses to restore maybe because I reinstalled Windows –  PHILIP KIRK Jan 11 '11 at 14:59
    
Was the reinstall done without errors? If you've reinstalled Windows then the icons should have been returned to normal. –  mickburkejnr Jan 11 '11 at 15:22
    
The reinstall went ok but icons did not alter, I thought they would return to normal but alas not –  PHILIP KIRK Jan 11 '11 at 16:02
show 2 more comments

If you go to Start->Default programs, you should be able to adjust which program should open each specific file type. On my machine, I have to click the top link ("Set your default programs") before I'm in the actual settings window.

There, you see a list of applications on the left, and two buttons at the bottom - "Set this program as default" and "Choose defaults for this program". The dialog windows are pretty self explanatory.

share|improve this answer
    
I have tried your suggestion but all of the shortcuts and icons stay the same and still open the same program. –  PHILIP KIRK Jan 11 '11 at 14:03
    
I have tried your suggestion on several programs but all it does is change all the shortcuts and icons to that program –  PHILIP KIRK Jan 11 '11 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.