Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to open files without file name extension, including .dotsystemfiles (e.g. .htaccess or .vimrc) with a different editor than TextEdit. Doing the regular Change All... in the Get Info panel won't do the trick as it gives the following error:

alt text

share|improve this question

2 Answers 2

up vote 19 down vote accepted

You need to change the editor for the text/plain mime type or public.plain-text UTI. The regular Get Info dialog changes the association for the file name extension, which these files don't have.


Get RCDefaultApp and install it.

Open System Preferences » Default Apps » Apps. Select your desired default editor, and look for either of the above in the application's list of supported types.

alt text alt text alt text

Select the entry, and click Set as Default. You're done. Both opening from Finder and the command-line open will open your new default editor.


This also changes all .txt files and the like. I don't think this can be prevented, since OS X thinks both these and extension-less files are public.plain-text/text/plain.


To do this without RCDefaultApp, edit Edit ~/Library/Preferences/com.apple.LaunchServices.plist.

Add an entry under LSHandlers, containing the UTI (key LSHandlerContentType, e.g. public.plain-text) and application bundle identifier (LSHandlerRoleAll, e.g. com.macromates.textmate).

It looks like this in Property List Editor:

alt text alt text

share|improve this answer
1  
Or choose the Mime types tab and choose what app text/plain is opened by (this allows Aquamacs.app to be used which does not have the Mime types shown in its list –  Mark Jan 11 '11 at 18:18
    
This worked for me. Thanks a lot Daniel. A couple things to add: I needed to log out of the OS and then back in. Also, curiously, .DS_STORE files still open in TextEdit by default, but all other .dotsystemfiles are now opening in my desired editor. –  jasonkuhrt Jan 11 '11 at 19:57
    
Is there a way to do this with defaults write instead of downloading third party software? –  MattDiPasquale Jan 20 '11 at 5:29
    
@Matt See my edited post. –  Daniel Beck Jan 20 '11 at 6:14
    
@Danel Beck, awesome, thanks! :) –  MattDiPasquale Jan 21 '11 at 1:17

You can also run plutil -convert xml1 ~/Library/Preferences/com.apple.LaunchServices.plist and add something like this:

<dict>
    <key>LSHandlerContentType</key>
    <string>public.plain-text</string>
    <key>LSHandlerRoleAll</key>
    <string>com.macromates.textmate</string>
</dict>
<dict>
    <key>LSHandlerContentType</key>
    <string>public.unix-executable</string>
    <key>LSHandlerRoleAll</key>
    <string>com.macromates.textmate</string>
</dict>

You can apply changes by restarting or by rebuilding the Launch Services database. Logging out and back in isn't enough.

Or add this to a duti configuration file:

com.macromates.textmate public.plain-text all
com.macromates.textmate public.unix-executable all

public.plain-text also includes files with a .txt or .text extension. I don't know any way to change the default application for files with arbitrary extensions.

public.unix-exexutable includes executable scripts without a filename extension. If you try to change the default application for them from Finder, there is an error like this:

The operation can’t be completed.

An unexpected error occurred (error code -50).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.