Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This used to work fine until a week or so ago, and I am not sure what has changed since then. I have just uninstalled what seems to be all the JVM stuff on my machine and reinstalled with the latest recommended Java version from (1.6, update 23). The plugin works fine in IE and Firefox, but in Chrome it fails and the pages that try to use the plugin act as if Java is not installed. I have tried this in both Chrome 8 and Chrome 9 with the same result.

How can I diagnose and fix this?

share|improve this question
What OS are you running? – user3463 Jan 11 '11 at 22:07
Sorry, yes, it's Windows 7. – Chris Farmer Jan 12 '11 at 2:20 is what i read and it helped me figure out how to make java work on chrome. – user108906 Dec 9 '11 at 14:39
@chastity: I have the same problem, and the Java plugin doesn't even appear in Chrome's list of plugins, so the link above doesn't help. Looks like it's the 64-bit Java vs. 32-bit Chrome issue. – Dan Dascalescu Apr 2 '12 at 3:10
up vote 23 down vote accepted

If you are using 64-bit Windows, only IE supports 64-bit Java. Chrome and Firefox will only work if you install the 32-bit Java.

For more details - Google support

share|improve this answer
Thanks! I had discovered this combination worked a while back but never updated my question. – Chris Farmer May 20 '11 at 15:51
Had the same problem. Uninstalling 64-bit Java and installing the 32-bit version fixed it. – Dan Dascalescu Apr 3 '12 at 20:30

it is an easy fix , I also had a lot of trouble with java in chrome

go to this web site

chose the 32 bit java FX for most people download and install your problem is ficex

I still have problem with emails though

share|improve this answer

Just now I ran into this issue, which was caused by an MSI installer trying to update Java and fracking things up. Basically Chrome looks at registry to find a better java version than the System32 one, so it accesses this registry key: HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins inhere,version=x.x.x is where the RIGHT path of the plugin is defined. Check that Path entry against the actual path and if it's not matching, that this is the issue. In a 32 bit Windows 7 it should be (or mine is) "C:\Program Files\Java\jre7\bin\plugin2\npjp2.dll".

share|improve this answer
Thanks! This worked for me. Also, if you don't have write access to HKEY_LOCAL_MACHINE, you can copy the HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins hive to HKEY_CURRENT_USER\Software\MozillaPlugins and modify it there to update the Java plugin for the current user. – richardneish Jun 25 '14 at 11:04
Hmmm, actually my current settings showed the correct version for the plugin, but Chrome hangs when I try to use the plugin. Will let you know if I get it working. – richardneish Jun 25 '14 at 11:10

You can also add URL of the site that you have problems with to the trusted sites in the Java control panel. Then, it will ask you if you want to run Java when you open the page.

This works across browsers.

On the OS X side, if you can't access the control panel, you can whitelist a site by adding it to the file /Library/Application Support/Oracle/Java/Deployment/security/exception.sites. You'll have to create the file if it doesn't exist.

share|improve this answer

I did all the above however after half an hour still cannot get it to run. I reviewed all steps, I already did correct. Eventually found that although I had closed the chrome user interface, the service still running which means chrome has not yet been restarted, so I killed that chrome process running in background, and IT WORKS!

share|improve this answer

I agree about the 32 bit Java for Chrome. Anyway, after installing Java for the gazillionth time, still not finding the plugin in chrome, I went to the control panel and clicked on Java 32bit. The Java Control Panel opened. Under the security tab I checked Enable Java Content in the Browser. Under the Advanced tab I checked the box under Java Plugin. Restart chrome and voila! :) Hope this works for you; I've been dealing with this problem for at least a month.

share|improve this answer

In a tab in Chrome type the following into the omnibar to open the Plugin list: chrome://plugins/. A list of installed plug-ins will be displayed. Find the Java plugin, then check the box "Always allowed".

share|improve this answer

Since version 45, Google Chrome no longer supports Java applets.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .