Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Visual Studio 2010 Professional at work and up until a couple of weeks ago I have had no problems. But now whenever I open an instance of VS 2010 it defaults to horizontal split. I never split my windows horizontally, so this is very annoying. It happens consistently, every time on every project.

Here is how VS2010 looked before I closed the window: alt text

I close it and reopen in that project, and: alt text

Arg! The only plugin I use is ReSharper, in case it's relevant.

share|improve this question
    
this is happening to me too but I don't have resharper installed. Very annoying since there's no way to switch it back without dragging all the windows off and then back on. –  DShook Jul 9 '12 at 21:44
add comment

5 Answers

I too had exactly this problem running VS2010 with no addins. It appears that everyone else submitting comments and solutions really hasn't understood the problem.

Here is my solution... The problem manifests itself when you close down Visual Studio with the windows in vertical tab groups. Then when you re open the solution FROM THE SOLUTION FILE, the tab groups are now grouped horizontally. (So no, nothing is "saved")

The problem does NOT occur if you open Visual Studio, then open the project from within Visual Studio!

share|improve this answer
add comment

This is actually a feature called Tab Grouping and it can be enabled horizontally or vertically. As far as I can tell, it's the same thing as a window split to enable you to see 2 or more sections of the same file simultaneously. The difference is that Tab Grouping is saved between sessions i.e. if you close and re-open Visual Studio, this setting will be retained!

To disable it:

alt text

In your particular case, you have 3 files opened in each group. This means you will have to repeat the procedure 3 times either starting on the left or right side and moving each file either to the left or right side until you only have one group open.

In case somebody wants to enable it (or the horizontal version):

alt text

UPDATE:
Googling around I was able to find numerous people complaining about all sorts of bugs with splitting/grouping code windows while using ReSharper. You could try removing ReSharper, ensure windows are not split/grouped, restart VS to verify if it worked, then re-install ReSharper?

share|improve this answer
    
You don't explain why this happens every time he opens VS. –  Daniel Beck Jan 12 '11 at 7:18
    
It is saved between sessions. Updated my answer. –  glenneroo Jan 12 '11 at 7:29
    
What do you mean it's saved? This makes no sense at all, I never set any kind of grouping, WHAT is saved? I have never in my life even touched a "grouping" setting. My question is why does VS CHANGE from vertical to horizontal splitting? –  Martin Doms Jan 12 '11 at 19:01
1  
You pasted screenshots. I have VS2010. I can recreate your screenshots by enabling grouping. Therefore you have somehow enabled grouping. What do you mean what do I mean it's saved? Are you a programmer? Saved means that the grouping of files is remembered between Visual Studio sessions i.e. if you enable the grouping feature, shutdown VS, and start it again, grouping of files will be restored. Have you tried doing what I suggested to disable it? If you're only interested in knowing why it changes, I suggest updating your question because I didn't see that question. –  glenneroo Jan 13 '11 at 8:36
add comment

I too had exactly this problem running VS2010 with no addins.

The problem only manifests itself when you close down Visual Studio with the windows in vertical tab groups. Then, when you reopen the solution from the solution file (i.e. double clicking on the .sln file), the tab groups are now grouped horizontally.

If you open VS2010 then open the project (e.g. from the recent projects list) then the tab groups are back as they were when you closed down VS.

share|improve this answer
add comment

I answered this at StackOverflow: http://stackoverflow.com/questions/11100726/how-to-change-horizontal-tab-group-to-vertical-tab-group

Basically, edit your VS settings file and remove the Orientation="Vertical" that is there.

share|improve this answer
add comment

Its very simple.

Just go to Tools -> Option -> HTML Designer -> General tab, check the option Split views vertically.

This will by default splits the window vertically always.

Note: This does not work for .master file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.