Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect my Elitebook 8440p laptop to my Samsung HDTV. The laptop does not have a HDMI connection, but it does have DisplayPort. I bought a DisplayPort-to-HDMI adapter here http://www.amazon.com/gp/product/B002CSRFD8/ref=oss_product, and connected it with a 3' HDMI cable. The video shows up fine, but there is no audio. DisplayPort, HDMI, and the adapter all support audio.

I contacted HP tech support, who told me to update my sound drivers. I installed the driver and rebooted. Supposedly, I should see a "HD Audio" tab. No luck, even after installing the driver again and rebooting. HP closed the case. I'm using XP Pro.

share|improve this question
add comment

5 Answers

I travel a lot – here is what I do:

  • plug in HDMI
  • turn on TV to right input etc...
  • close the lid and let it go to sleep wait a few seconds
  • open the lid then quickly close it
  • wait for it to output video to the TV (you may need to reboot with lid closed)
  • then open the lid if you need to setup screens etc.. I found the intel software left in clone mode works great! My res is 1280x720

I use a display port to HDMI dongle but it should not matter.

share|improve this answer
add comment

This can be achieved by reloading HD sound devices

  1. Launch device manager
  2. Select sound video and game controller
  3. Uninstall HD sound device(s)
  4. scan for new hardware
share|improve this answer
add comment

The HP support did try to help, but they failed to troubleshoot the problem, and ultimately gave up too soon. Despite what HP support tells me, there is no HD Audio tab.

Thank you Crujach and Paul for your ideas. These got me on the right path, and before too long I figured it out.

Here's what I did:

  • I started at my desk. iTunes was open, playing U2 through the laptop speakers.
  • I carried the laptop (still on) to the living room and connected to the home entertainment center receiver through the HDMI/DisplayPort connection.
  • I went to Control Panel / Sounds and Audio Devices / Audio tab / Sound Playback default device
  • It was set to IDT Audio, and there was no other option available.
  • I put the computer into Standby, and powered it back up.
  • In the control panel, I could now choose between IDT Audio and NVIDIA High Definition Audio
  • I chose NVIDIA High Definition Audio and clicked on Apply. Sound still came through the laptop speakers.
  • I shut down iTunes, restarted it, and now it worked correctly.

The signal comes through DisplayPort, through the DisplayPort/HDMI adapter, through the HDMI cable to the home entertainment receiver, and out the surround-sound speakers.

To summarize:

  1. Turn off your application (iTunes, internet browser)
  2. Put computer on Standby
  3. TV and receiver should be ON
  4. Connect to TV or receiver via HDMI cable (and DisplayPort-HDMI adapter)
  5. Come out of standby (or restart)
  6. Control Panel / Sounds and Audio Devices / Audio tab / Sound Playback default device
  7. Select NVIDIA High Definition Audio and click on Apply
  8. Open your application (iTunes, internet browser)
  9. Make sure sound on laptop is turned to maximum and not muted
share|improve this answer
    
Good job figuring it out, that makes sense. I did find a small app that automatically switches audio inputs, you might try it. The author has said he believes it to work in XP: coastalaudiochanger.wordpress.com –  Paul Jan 20 '11 at 14:19
add comment

I had a similar Issue with a HP Small Form Factor PC.

  • applied all avaliable Driver Updates
  • after investigatig the BIOS (search if there is a Option in the BIOS to switch from SPDIF to HD Audio Output)
  • serching for an Option in Windows XP - Control Panel - Sound and Audio devices to change the Output Device to HD Audio

I decided that the Display-Port does not support Audio and connected a Male/Male Audio-Cable from the PC to the TV and connected the HDMI-Cable to the according Port (on the TV was a Audio-Input 'HDMI/PC/DVI-D AUDIO IN' which is working together with one specific HDMI-Port)

This last step worked fine for me.

share|improve this answer
add comment

I ran across this same issue recently with my Dell Latitude running an Nvidia NVS3100 mobile graphics card, using a similar adapter to a 24" HDMI Dell monitor and from researching, I found that Audio is an optional signal with Displayport 1.1a. Most hardware these days is enabled, but updated drivers are a must, which is why the support told you that. Quite rude to shut you down without giving you a link to the driver, however.

The HP forum thread below may have a solution for you, as they're using similar setups and have found working solutions. I don't have an actual solution here, I'm merely trying to be of use as I struggled to get my issue resolved recently and I know what a pain in the butt it can be!

Sources:

  1. Displayport FAQs

  2. HP forum

Edit:

I also just found these tips that might work for you:

On a machine with a discrete graphic card - just choose NVidia HD audio as playback device after connecting your display. On a machine with an integrated graphic card - the trick is to go to Control Panel > Sound control panel > Right click on your TV > Select 'Set as Default Device'. Then you should start hearing audio out from the TV speakers, and the green sound volume meter beside the TV in the Sound Control Panel should start responding to the audio you're playing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.