Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen a number of references to /etc/com.apple.named.conf.proxy for use with named in Internet Sharing on Mac OSX. On my Snow Leopard 10.6.6 Macbook Pro, though, no such file seems to exist. Is this handled in a different way now?

share|improve this question
    
That file exists for me on 10.6.6. –  fideli Jan 12 '11 at 2:14
add comment

2 Answers

The file is created when Internet Sharing is activated in System Preferences.

Note that unix-y paths such as /etc, /dev, /bin don't regularly show up in Finder. Either go command-line via /Applications/Utilities/Terminal.app or use Finder » Go menu » Go to Folder....

share|improve this answer
    
$ sudo ls /etc/com.apple* Password: ls: /etc/com.apple*: No such file or directory –  umop Jan 12 '11 at 23:25
    
@umop have you activated Internet Sharing in System Preferences? Tried toggling it? –  Daniel Beck Jan 13 '11 at 5:48
    
Yes. It was activated (checked, at least). It turns out that the problem was that no adapters were selected for sharing, so it was just skipping the sharing altogether (I'm guessing). –  umop Jan 22 '11 at 5:05
    
@umop True. Although my machine automatically disables the activation checkbox when no adapters are selected for sharing, or sharing is running. –  Daniel Beck Jan 22 '11 at 7:30
    
I remember that being the functionality as well. Whether it's a bug or a new updated feature, it looks like that did not occur in this case. –  umop Jan 24 '11 at 16:24
add comment
up vote 0 down vote accepted

The problem in my case was that no adapters were selected for sharing, so it was just skipping the sharing altogether. It was pointed out that MacOS typically automatically disables the activation checkbox when no adapters are selected for sharing, but that did not occur for me (perhaps a bug)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.