Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a macbookpro that wont boot properly. I've tried resetting the PRAM (holding down option - alt - P - R), but it doesn't work, it gets halfway through the boot process and says "You need to restart your computer" in several languages.

Recently I downloaded a USB Key compatible Linux OS. This USB Key works as a boot loader on Windows machines, but on OSX it can only find the Harddrive partitions when I go into the boot loader menu (holding down Option on startup). I am assuming it is because it is formatted as FAT32, and not GUID Table.

I believe my CD drive is also bust, it hasn't worked in a long time.

I don't have another Mac computer, so is there a way I can format the USB key as GUID Partition from a windows 7 machine?

share|improve this question
add comment

2 Answers

http://www.microsoft.com/whdc/device/storage/gpt-on-x64.mspx#EHC

As an alternative, if you have or can borrow another computer with Firewire (not necessarily a Mac), start your Mac up with the 'T' key held down to enter . Then, connect it to the other computer, where it will show up as an external Firewire disk. You'd need to get hold of some Windows HFS+ drivers to read any of the data, though.

Also, have you tried booting into Safe Mode (hold 'shift' on startup)?

Finally, if you haven't already, give your CD drive a go - try to start up from the software restore disk that came with your Mac by booting with the 'C' key held down. That's the go-to way of recovering an un-bootable Mac. If your CD drive is dead and you can't beg, steal or borrow another Mac you may have to permanently settle for Linux.

share|improve this answer
    
Oh Crap - it won't even power on now. Pronounced dead at 09:15am. –  digiguru Jan 13 '11 at 9:25
    
One last desperate thing you could try would be to reset the SMC: support.apple.com/kb/HT3964 If that doesn't work, I fear not even Linux will fix your problems - it sounds like a major hardware fault. My commiserations. –  Scott Jan 13 '11 at 10:21
add comment

AFAIK Windows 7 does only create partitions on an USB storage device if it announces itself as USB HDD, on a regular USB stick which announces itself as simple removable USB stick you can not even create a partition - whether GUID nor MBR.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.