Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently switched from Ubuntu to kubuntu, both version 10.10. Unfortunately in KDE the ssh passphrase dialog doesn't work out of the box. Everytime my ssh private key is used I need to enter my password. This is neither secure nor comfortable.

I have done comprehensive research on the net but only found out dated documentation. Several things I tried didn't work out. Current status:

  • SSH setup working with direct passphrase input
  • ssh-agent running in X session
  • $SSH_AUTH_SOCK set to ssh-agent's socket in X session

How to enable ssh-agent for keeping the passphrase in memory for ~15mins and as a bonus always use a graphical dialog for its input?

I use asymmetric SSH key pairs for

  • pushing/pulling in Git VCS
  • logging remotely into different server systems
share|improve this question

Even if ssh-agent is running, it's not used until you add some keys to it - as in ssh-add.

As for graphical passphrase inputs, those are not part of ssh-agent nor ssh-add. In GNOME, they're displayed by an entirely different program, GNOME Keyring Daemon (which also acts as a ssh-agent replacement). I'm not aware of a KDE analogue.


There is a way to get graphical input with ssh-add, by pointing the SSH_ASKPASS environment variable to an apropriate "askpass" program, then running ssh-add < /dev/null.

I personally use the pinentry program from GnuPG (has both KDE and GNOME frontends, but must be used through a wrapper script). There seems to be a ksshaskpass package available for Ubuntu, too.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .