Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hello I am trying to upload and download files from my desktop to my server. Now after some search I did download psftp. I used to use filezilla earlier, but I cannot install it on my desktop due to a few reasons. Since psftp (similar to putty) is just an executable for file transfer.

So now after going through this link http://www.math.tamu.edu/~mpilant/math696/psftp.html. I understood that put and get are two commands I would use to download and upload files. Now when I logon to the server and say get filename, it actually is throwing back an error "local: unable to open filename". I tried that with other files too, and I end up getting the same error.

The psftp.exe file is on my desktop. The process that I am using is

  1. I double click the .exe file

  2. open "servrname"

  3. cd /path/where/files/are

  4. get "filename"

And I get this error

"local: unable to open filename".

Am I making a mistake or is it a problem with this executable?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

It sounds like a local permissions issue to me. Try using the 'lpwd' command to determine the local directory you are in. You can use 'lcd' to change the local directory you are downloading to, if the one you are in does not work.

share|improve this answer
    
when I hit lcd , it says expects local directory name. When I hit lpwd it gave me my desktop's address. –  macha Jan 12 '11 at 19:27
    
The 'lcd' command allows you to change the local directory. For example: 'lcd /temp' puts you in the C:\Temp directory. Does the file you are downloading have a nonstandard name or something? –  Jeremy Vanderburg Jan 12 '11 at 19:30
    
well it is a regular file, name is info.pl, and that is the only file with that name in the directory I am working in. –  macha Jan 12 '11 at 19:32
    
I have these permissions on the file "-rw-rw-r-- me me filename", that should mean that I own the file and have write permissions right? –  macha Jan 12 '11 at 19:33
    
Ok the folder is owned by the administrator, but I am the owner of the files, can I still download the files? –  macha Jan 12 '11 at 19:35

Alright sorry for troubling you guys, my folder was locked down, so I did not have write access to the destination folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.