Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 64-bit. I've installed Windows Virtual PC and Windows XP Mode successfully.

Next, I downloaded Ubuntu Server 9.04 32-bit. I created a new virtual machine with a dynamically expanding .vhd, loaded the Ubuntu .iso, and booted the machine. I successfully made it through the install, but when the machine reboots, I get a segmentation fault. Here is a screenshot:

enter image description here

Has anyone successfully installed Ubuntu on Windows Virtual PC?

share|improve this question

11 Answers 11

I would recommend using VirtualBox instead. Windows Virtual PC was designed with only Windows in mind, but with VirtualBox, you can install any OS you want. I've been running Ubuntu on it without any problems.

share|improve this answer

There is currently no Virtual PC Extensions for Linux available for the new Virtual PC, however it has been mentioned that the Hyper-V extensions might possibly work. However Microsoft mainly support SUSE Linux and RedHat based server OS's and not the desktop editions. The current extensions are only available for Virtual Server 2005 and Hyper-V.

I have to agree with musicfreak's recommendation of VirtualBox. It is the best VM manager to run Linux with. However Hyper-V with a RedHat or CentOS installation is not to bad.

share|improve this answer

It's memory... I had all the same errors as the others until I bumped the memory of the Ubuntu Virtual PC to 1024 instead of the default 512M. Looks good...

share|improve this answer

I'm running Ubuntu Server under Windows 7 7100 host, in VMWare 6. Works great.

share|improve this answer

Yes, you can!

A while ago I wrote a blog post on how to install Ubuntu Server 9.10 on Virtual PC under Windows 7.

I have now just posted an update on how to get Ubuntu Server 10.10 to work as well.

share|improve this answer
Adding "noreplace-paravirt vga=771" in grub fixed it for me. Thanks! I still get some "cannot reserve framebuffer region" errors on boot, but I cna at least get to a shell now. – rally25rs Mar 3 '11 at 18:35

It's memory... I had all the same errors as the others until I bumped the memory of the >Ubuntu Virtual PC to 1024 instead of the default 512M. Looks good...

Same for me! i.e. solution is to bump up the memory of the>Ubuntu Virtual PC to 1024

share|improve this answer

There have been quite a few issues with virtual pc and ubuntu, most of them relating to screen resolution afaik. Though I have not tried it myself recently I would suggest looking at these tips

share|improve this answer
I'm using Windows Virtual PC. It's the new Virtual PC built for Windows 7, so I'm not sure how many of those tips apply. – Lance Fisher Aug 15 '09 at 21:34

I installed ubuntu 9.10 on windows 7 with the final virtual pc version and got the segmentation faults as well.

When I change my network settings in virtual pc (I had 2 NICS) to only 1 nic with No Network it booted.

So I'm running Ubuntu now in VP windows 7, but have no mouse support yet.


share|improve this answer

Yeah same here - 9.10 ubuntu server on windows 7 64 Virtual PC always crashes. I guess there's always the desktop version. I installed it on virtualbox just fine.

share|improve this answer

From my side, need more than 1024M and yes only 1 NIC. Bad side, Mcsft dont supply integreated fonctionnality for Ubuntu so, no sound.

share|improve this answer

I had the same problem but I bumped the availible RAM up to 1024MB and it booted right away with no segfaults.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .