Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today, I started toying around with installing DroboApps on my DroboShare.

I first installed the Drobo Admin Utility, which allowed me to simply install Dropbear SSH so that I can ssh into my DroboShare. However, then I got the "ingenious idea" to start messing around with the /etc/passwd file...

Now I can't login using ssh anymore, I think I changed the password or something, but can't find a way to reset it. I tried uninstalling SSH via the Admin Utility and then reinstalling it again, but that didn't help.

Does anyone know of a way to reset the password to the default?

share|improve this question
I can't even get Dropbear to open up the listen port 22 after install, there by stopping me from logging onto my Droboshare. – user248272 Aug 25 '13 at 0:15
up vote 2 down vote accepted

When cleaning my desk (that Drobo collects a lot of dust, just by sitting there for a year), I found a little hole on the back of the DroboShare.

It turns out that there is a hardware reset button on the DroboShare. By using a straightened paperclip you can reset it to the factory defaults without deleting any data on the actual Drobo.

Here's a quote from the "How do I reset DroboShare back to default settings" question in the Drobo Knowlege Base (in case the original goes down):

  1. If possible, first put Drobo into standby mode.
  2. Power down DroboShare:
    • Disconnect the Ethernet cable
    • Wait one minute
    • Disconnect the power cable of DroboShare only. Be sure not to disconnect the power to Drobo.
  3. Locate the small hole approximately 1" to the left of the DroboShare Ethernet port. It is the hole for the reset switch.
  4. Insert a straightened paper clip into the hole and depress the reset switch inside.
  5. Hold the reset switch depressed while simultaneously connecting power back to DroboShare. Keep it depressed until the power light on Drobo is solid green (not blinking) and its drive lights are solid green.
  6. Release the paper clip and disconnect DroboShare's power cable again.
  7. Power up DroboShare:
    • Connect the Ethernet cable.
    • Connect the data cable (if it was disconnected).
    • Connect the power cable back to DroboShare.
  8. Wait at least 2 minutes for it to mount.
share|improve this answer

You must reset your DroboShare to default settings, but this operation delete all your data!

share|improve this answer
Do you mean I have to click the Reset button in the Drobo Dashboard that erases both the Settings on the DroboShare and all data on the Drobo? In my case that's not a problem because I'm planning to format the Drobo anyway, since I've partitioned it wrong. But in general that's very annoying. – Tom Lokhorst Aug 18 '09 at 8:02

Yow! This is a pain and I bet it's going to happen to more people. I bet I know what you two did--and it didn't have anything to do with fiddling with your password. It was the other thing you changed: your shell. If my guess is correct, you, like me, installed bash as well as dropbear (which, by the way, just starts it; it's already on the box). Then either you symlinked bash into /bin/ or you modified the passwd file to point at /mnt/DroboShares/....

Sooo... I did this. And then, before logging out, I tried to log in in another tab. After a bunch of fiddling around (and no love from Google except this page), I figured out that changing the shell back to /bin/sh allowed me to log in again. Changing the password is not a problem.

On a fully-fledged box, there would be an /etc/shells file that listed login shells, but there is no such file on my DroboShare.

So far, I haven't figured out how to get DroboShare to execute bash on the Drobo mount.

But back to passwords... In addition to changing your password, you can instead use an ssh authorized_keys file. Both rsa and dss public keys work, but note that the name authorized_keys2 won't. And your .ssh directory (and/or?) authorized_keys file need(s) to be mode 600, which probably won't happen by default because there is no umask command in /etc/profile, so typically your umask is 0 instead of the typical 22.

share|improve this answer

Install Openssh then sudo (

login using ssh with the Admin account.

Then go to /mnt/DroboFS/Shares/DroboApps/sudo/bin

run ./sudo su -

You are the root and can change the root passwdord back to something you can remember.

To stay secure, you can remove sudo after that.

share|improve this answer

I just spent the last 3 days trying to figure this out -- I also (mistyped?) my droboShare root password and got locked out.

The Answer is: you need to re-install the DroboShare FIRMWARE. Just re-install the same DroboShare firmware you (currently have) and that will reset the Linux internals (well.. at least the /etc/passwd file :-). You will have to reset everything else associated with your DroboShare (DHCP) and so for once your DroboShare reboots.

No promises on whether you lose all of your existing Drobo data or not -- I started with a "who cares" Drobo and DroboShare - so I was fine with losing all of the data on it.

==> User beware!

Have fun.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .