Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got a new 2TB drive which I'm trying to use as a time machine drive for my mac which has a 1TB drive. On my first time trying to back it up, I'm getting terrible throughput, not even 1GB per day (it's been running for 36 hours now).

I erased the disk and tried to copy a large file to it and got the same slow speed. What can I do to diagnose this? Are there any tools which can inspect the disk and tell me if it's messed up?

Thanks!

share|improve this question
2  
How is the drive connected to the Mac? If it's connected through, say, a slow USB-1 keyboard or hub, that might explain it... –  Gordon Davisson Jan 13 '11 at 6:05
    
So this question has nothing to do with Time Machine, since it also happens for regular file copies? –  Daniel Beck Jan 13 '11 at 6:37
    
How to find out your connection speed: Click the Apple icon in the top left of your screen, press Option, and select System Profiler... (the first entry). Select USB on the left, and look for your hard drive's Speed. –  Daniel Beck Jan 13 '11 at 6:39
    
Gordon: it's connected directly. –  lowellk Jan 13 '11 at 17:32
    
Daniel: You're right, I shouldn't have mentioned time machine. –  lowellk Jan 13 '11 at 17:33

1 Answer 1

up vote 0 down vote accepted

Did you perform a complete reformat, or just erase it? To do a full format,

  1. In Disk Utility, select the drive itself, not just one of its partitions
  2. Click "Partition"
  3. Under "Volume Scheme", select "1 Partition"
  4. Click the now-enabled "Options" button, and ensure GUID Partition Table is selected
  5. Ensure "Format" is set to "Mac OS Extended (Journaled)"
  6. Click "Apply" to completely reformat the disk.

If that doesn't work, and other drives connected to your Mac don't exhibit this problem, and you've tried using a different USB cable, then you may have a defective drive.

share|improve this answer
    
Hmm, seems like I may have a defective drive. Thanks for you help. –  lowellk Jan 24 '11 at 1:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.