Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop, I've installed the beep package. I turned every sound to full, and I do this:

$ beep

But I can't hear any beeping sound. What am I missing? I just need to run the beep when a script is finished.

share|improve this question
    
If all else fails, then maybe the echo -e '\a' > /dev/console alternatives from Remotely make the computer beep on built-in speaker can help. – Arjan Jan 13 '11 at 11:59
    
I've corrected the spelling and formatting. You don't need a <br> after every line. Press Enter twice or include two spaces at the end of a line. – nyuszika7h Feb 5 '11 at 15:46

Ubuntu had an issue where some installs would beep on shutdown causing much annoyance. Their solution was to blacklist pcspkr for all installs. That may be what Fedora did. Take a look through your /etc/modprobe.d/blacklist (or Fedora equivalent) to see if it has an entry and try running modprobe pcspkr to make sure it's installed.

share|improve this answer
    
Nice, that might explain why modprobe pcspkr was mentioned in an unrelated question too! – Arjan Jan 13 '11 at 12:56

As of Fedora 17, I had to install xkbset and run xkbset b to enable the Audible Bell as it was disabled by default. (That, and make sure the kernel module pcspkr is loaded. The beep rpm puts a /etc/modprobe.d/beep.conf in place - you'll want to un-comment the appropriate line in that and/or run modprobe pcspkr if you haven't already.)

I hope that helps,

Adam

share|improve this answer

Many terminal applications have the option of turning off the beep sound. Look in you terminal's settings.

share|improve this answer

According to a comment at an answer at Remotely make the computer beep on built-in speaker:

gnome-volume-control can be used to control the built-in speaker separately.

So, maybe the volume level is tuned down?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .